No sound after full-upgrade

Briefly describe your issue below:
Did a full upgrade yesterday and lost all sound.

sudo lspci:
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)

From another thread tried:
sudo curl -s https://raw.githubusercontent.com/nu11secur1ty/pulseaudio/master/pulseaudio.sh 2 | bash

result:
[+] Preparing pulseaudio
bash: line 10: /usr/local/bin/pulseaudio.sh: Permission denied
chmod: cannot access ‘/usr/local/bin/pulseaudio.sh’: No such file or directory
bash: line 14: /root/.config/autostart/pulseaudioscript.sh.desktop: Permission denied
After reboot your system everything will be ok with your audio controller. Have fun with nu11secur1ty -:wink:

Reboot. No sound.

Tried uninstalling pulseaudio and rebooting, then reinstalling it, sound returned. After next reboot it was gone again.

If relevant cinnamon is installed, just cinnamon, not the complete desktop environment, and sound worked with cinnamon installed until full-upgrade. But sound also doesn’t work on Mate desktop, and sound>hardware shows no entry. I also did a complete reinstall of the system but same problem.

Thanks

What version of Parrot are you running? (include version, edition, and architecture)
Parrot Sec 4.1 stable
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian GTK
Configured to multiboot with other systems? (yes / no)
No
If there are any similar issues or solutions, link to them below:



If there are any error messages or relevant logs, post them below:

Thanks

If Firejail causes PulseAudio issues with sandboxed applications [3], the following command may be used:
Try this : open terminal and you do : firecfg --fix-sound
This commands creates a custom ~/.config/pulse/client.conf file for the current user with enable-shm = no and possible other workarounds.

Thanks for the quick reply jarfr, but it didn’t fix it. Still no sound from anything. After reinstalling the system, I checked the sound and it worked but full-upgrade killed the sound again.
Only uninstalling pulseaudio brings HDA Intel PCH back to applications>sound>hardware and gives sound back to at least vlc, smplayer, etc, but then firefox, kodi and I don’t yet know what else is without sound.
I really like the distro, but sound is essential.

you have logout and login after firecfg --fix-sound ?

Thanks jarfr, but it’s no use, logout/in, restart, full reboot, even complete reinstall, the problem persists. Zero sound from anywhere. It’s just totally screwed.

https://wiki.debian.org/PulseAudio#Installing_PulseAudio
https://www.vivaolinux.com.br/dica/Testando-microfone-pelo-terminal-sob-o-ALSA

So, for the final time I completely reinstalled the os. After updates sound was there. Then I installed the following;

clementine
audacity
soundkonverter
brasero
k3B
gtkpod
smplayer
winff
kdenlive
kodi
deluge
gimp
inkscape
darktable
shotwell
fotoxx
blender
raw therapee
okular
pdfchain
convertall
calibre
firetools
geany plugins
kleopatra
telegram
stellarium
kstars

applications>sounds>hardware…nothing, gone again, no sound.
Is there anything in that lot that could possible cause this, as before installing them the sound wss there and only gone after their installation?

I had the same problem. That worked for me:
sudo modprobe snd-hda-intel

Thanks for the help from you all, but nothing offered worked. I’ve given up and decided to reinstall Linux Mint and run Parrot via virtualbox without the extra apps. Everything seems to working fine this way.
Cheers

I tried the command and yet no sound.
uname -a
Linux parrot 4.16.0-parrot12-amd64 #1 SMP Parrot 4.16.12-1parrot12.1 (2018-05-28) x86_64 GNU/Linux
lsb_release -a
No LSB modules are available.
Distributor ID: Parrot
Description: Parrot 4.1
Release: 4.1
Codename: stable

lspci
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)

I also tried to delete the content of pulseaudio directories:
$ rm -r ~/.config/pulse /tmp/pulse-*
$ pulseaudio --kill
$ pulseaudio --start

I am lookin forward for tips on how to solve this.
Thanks.

~$aplay -l
list of playback hardware devices…
I have the right codec for the HDA intel PCH… Alc1220… this is for my headphones and rear Headphone jack…
nvidia HDMI… works… that is through HDMI… but the headphones are not…
what you got in you system:preferences:hardware:sound… i have default and nvidia…
Default should be using driver which is the same as lspci
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05 and i think the problems the controller… but i am not sure… i know i have sound with steamOS… SMBus: Intel Corporation 200 Series PCH SMBus Controller…
lspci -v | grep audio
lsmod | grep snd
so the default should be the acl 1220 which was included in the 4.1 kernel…
outputs this… generic realtek… snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek,snd_pcm
soundcore 16384 1 snd
┌─[in4m3@parrot]─[~]
└──╼ $lsmod |grep snd
snd_hda_codec_hdmi 57344 1
snd_hda_codec_realtek 110592 1
snd_hda_codec_generic 86016 1 snd_hda_codec_realtek

still looking at it… as i was searching for an answer myself here…

I have this problem too. I am using a usb audio inferface. It was working fine before the update. The problem seemed to be that Alsa reordered the sound cards making the on broad card the default. I disabled all other cards apart from the usb using the alsa blacklist conf. Now things like vlc work. However, firefox still outputs no sound as well as system sounds. The sound prefernces seems broken on this current build.

(Also I don’t like that red line around login panel in this new update)

https://wiki.debian.org/PulseAudio#Installing_PulseAudio

Any ideas with this error?

Daemon startup failed

I think pulseaudio is in the wrong directory on my build.

please start a new support topic instaed of necroing this one. try a clean install ive never had this issue so i woukldnt know how to help youv there.

Solution for no sound in Parrot
Open terminal
Type
sudo apt-get install pavucontrol
then
pulseaudio --start
Then restart your pc.
This will fix your problem.
Welcome

its because of audacity
you have to change the output device there
i got same problem a days ago while i was doing some audio steganography
you have to change the output device there
or if not try uninstalling the audacity it will work back as charm