No sound in Parrot OS - Fixed

1. Your Parrot information

  • OS version: run cat /etc/*release
    DISTRIB_UD=Parrot DISTRIB_RELEASE=4.10 DISTRIB_CODENAME=rolling PRETTY_NAME="Parrot GNU/Linux 4.10"
  • Kernel version: run uname -a
    Linux parrot 5.7.0-2parrot2-amd64 #1 SMP Debian 5.7.10-1parrot2 (2020-07-31) x86_64 GNU/Linux

2. If you have this problem after fresh installation:

  1. How did you create USB bootable?

    • Using balena-etcher-electron-1.5.113-linux-x64
  2. How did you install OS?

    • Debian installer

3. If your hardware doesn’t work:

Problem: I bought a new computer with a NVIDIA Quadro RTX 3000 graphic card and the audio device that comes with it is the NVIDIA TU106 High Definition Audio Controller. I made a partition and installed Windows in one side and Parrot Home in the other. The audio worked completely fine in Windows, but not in Parrot. I think it has something to do with compatibility issues, but not with Parrot but with most Linux in general (I tried to install Manjaro too and the audio didn’t work either.)

I tried to install the latest NVIDIA drivers but it didn’t work. Don’t know if it was my fault during the installation process or if it just didn’t work. (You have to be out of the computer’s session, put Nouveau controller in a blacklist and some other things)

So after a lot of tries, I don’t know how I started my computer today and the sound was working. I’m going to explain the changes I had to do, maybe it can be useful to someone:

This solution enables the “Built-in-Audio” not the “TU106 High Definition Audio Controller”. I didn’t manage to make it work (I have enabled it in other tries, but still didn’t work). So now I have something like this:
image

Before the solution, that Buit-in-Audio wasn’t there, It was just the TU106 High Definition Audio Controller disabled.

My lspci output is this:

00:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 0d)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 0d)
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile) (rev 02)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 0d)
00:12.0 Signal processing controller: Intel Corporation Cannon Lake PCH Thermal Controller (rev 10)
00:13.0 Serial controller: Intel Corporation Device a37c (rev 10)
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
00:15.0 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller #0 (rev 10)
00:15.1 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller #1 (rev 10)
00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
00:16.3 Serial controller: Intel Corporation Cannon Lake PCH Active Management Technology - SOL (rev 10)
00:17.0 SATA controller: Intel Corporation Cannon Lake Mobile PCH SATA AHCI Controller (rev 10)
00:1b.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #17 (rev f0)
00:1c.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #3 (rev f0)
00:1c.4 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #5 (rev f0)
00:1d.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #14 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Cannon Lake LPC Controller (rev 10)
00:1f.3 Multimedia audio controller: Intel Corporation Cannon Lake PCH cAVS (rev 10)
00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (7) I219-LM (rev 10)
01:00.0 VGA compatible controller: NVIDIA Corporation TU106GLM [Quadro RTX 3000 Mobile / Max-Q] (rev a1)
01:00.1 Audio device: NVIDIA Corporation TU106 High Definition Audio Controller (rev a1)
01:00.2 USB controller: NVIDIA Corporation TU106 USB 3.1 Host Controller (rev a1)
01:00.3 Serial bus controller [0c80]: NVIDIA Corporation TU106 USB Type-C UCSI Controller (rev a1)
02:00.0 Non-Volatile memory controller: Sandisk Corp Device 5006
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
05:00.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)
06:00.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)
06:01.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)
06:02.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)
06:04.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)
07:00.0 System peripheral: Intel Corporation JHL7540 Thunderbolt 3 NHI [Titan Ridge 4C 2018] (rev 06)
3b:00.0 USB controller: Intel Corporation JHL7540 Thunderbolt 3 USB Controller [Titan Ridge 4C 2018] (rev 06)
70:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)
  1. Install pavucontrol and check AlsaMixer

Pavucontrol is a tool to control the PulseAudio volume. AlsaMixer graphical mixer program for ALSA that is the kernel level sound mixer, it manages your sound card directly. (https://www.linuxquestions.org/questions/linux-software-2/pavucontrol-and-alsamixer-878837/)

I put the AlsaMixer volume for all the sound cards to the highest value, just in case.

  1. I got the solution that worked for me from this page: https://askubuntu.com/questions/1222600/sound-not-working-on-ubuntu/1223922#1223922

The solution is the following:

  • Edit /etc/modprobe.d/alsa-base.conf as root and add options snd-hda-intel dmic_detect=0 at the end of this file by writing this on the terminal:
echo "options snd-hda-intel dmic_detect=0" | sudo tee -a /etc/modprobe.d/alsa-base.conf

In my case, I didn’t have the file alsa-based.conf. So I created a new one and added only that line.

  • Edit /etc/modprobe.d/blacklist.conf as root and add blacklist snd_soc_skl at the end of the file by writting this on the terminal:
echo "blacklist snd_soc_skl" | sudo tee -a /etc/modprobe.d/blacklist.conf

Same here, I created the file blacklist.conf and then I added only that line.

  • After this, I restarted the computer and now the Built-in-Audio appears in the Sound Preferences window. Make sure that in the Output tab, the Connector is set to Speakers and not headphones. It works now!!
    image

NOTE: If someone figures out how to make the TU106 High Definition Audio Controller work I would really like to know the solution.

1 Like