No wifi adapter with 5.14.0-2 but normal with 5.10.0-8

I have a laptop with perhaps an older version of Parrot, maybe 1-2 months old. I noticed on kernel 5.14.0-2parrot1-amd64 the wifi adapter does not work. I then rebooted with kernel 5.10.0-8parrot1-amd64 and instantly wifi worked from start.
Before I had no wifi listed with ifconfig and could not start wifi with ifconfig wlan0 up.

Is this error already known?
Laptop is a Panasonic CF-53.

€dit:
With a newer kernel the iwlwifi driver does not load apparently. lshw lists the wifi0 as unclaimed with a newer kernel than 5.10.0-8.

Maybe yeah,
I’ve heard that some Wi-Fi cards are not supported by this kernel.
But still one of our user sent a solution which worked for them - Telegram: Contact @parrotsecindia

I Found Solution For Wifi Not Working/Not Showing in Network Problem:
1.go to BIOS setting and navigate to BOOT menu
2.set boot mode Legacy support and boot priority as UEFI first
3.Thinks to ENABLE:
Fast boot -enable
PXE boot to LAN -enable
IPV4 PXE LAN first -enable
4.In EFI priority Setting,use F6 or f5 to make it
move EFI PXE Network (xx-xx-xx-xx-xx-xx) to first
move your to second

thats all you do…
5.Don’t forget to save changes,Press F10 and select Yes

But whatever it is, please make sure to keep your system updated as shortly as possible.
And to update » sudo parrot-upgrade.

This laptop has no UEFI Bios and therefore no Legacy support. But I would not enable it either because I also have Windows XP and DOS as bootable OS in parallel, these might not boot otherwise.

I did a parrot upgrade, but the wifi was not useable. Interestingly the touchscreen was not useable as well, as soon as I booted with the 5.10.0-8 driver both touchscreen and wifi works immediately.

I have now removed all kernels above 5.10-8.