No wifi on Mid 2010 MacBook Pro

Recently I was about to turn my Mid 2010 Macbook Pro into a Linux laptop and I decided on Parrot OS after few friends suggested me to. Problems accoured when I tried to install it for the first time during Live Boot, it stopped at the grub installation section showing " The ’ grub - pcpackage failed to install into / target /. Without the GRUB boot loader, the installed system will not boot.", after that I decided not to do a Live Boot, but to try the Install option from the boot menu, this time it worked and I successfully booted into Parrot Home but I could not connect to any WiFi network, not even a hotspot, the ethernet worked really good, but WiFi wasn’t visible anywhere. So the main question is, how do I get the WiFi to work on MacBook Pro Mid 2010.? I’m not a very tech savy person, I know roughly the basics of computing, but would really appreciate the help!

What version of Parrot are you running? (include version (4.6), edition(Home), and architecture (currently we only support amd64)
Version 4.6 Parrot Home

What method did you use to install Parrot? (Debian Standard)
Debian Standard

Configured to multiboot with other systems? (yes)
Yes, with Mac OS X High Sierra

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

My suggestion would be to do this:
while connected via eth0 install airport-utils from synaptic or use

sudo apt-get install airport-utils

Then restart and see if that will help. Also you may need to add some drivers for the wifi card. If you run ifconfig do you see the wifi card at all?
How about iwconfig?

My last thought:
Version 4.6 gave me issues with verified, working USB wifi cards along with a lot of other people. Not sure if that issue has been patched/fixed yet. I went back and installed an older version of Parrot Security then upgraded it and the problems were gone. Only happened on a fresh install of 4.6 for me. If I upgraded the older version manually through terminal I had no issues at all.