Not detecting window during installation

Briefly describe your issue below:
Hello, I am new here.

I am trying to install parrot os alongside windows 10 but I am facing problem two first it is not detecting my ethernet card and second grub are unable detecting window 10.

Could you tell me what should I do?

What version of Parrot are you running?
Latest version 4.6

What method did you use to install Parrot? Debian Standard

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

If you are trying to install Parrot OS, use latest version
Download Link: https://parrotsec.org/download/
and see if the issue still arises.

1 Like

I tried to reinstall Parrot from an old 4.6 usb and it resulted in chaos on my machine.Downloaded fresh up to date version from the above link and all sweet and rosey.
bing

1 Like
  1. Boot and mount your Windows partition
  2. Run the following on the command line
sudo os-prober
  1. If your Windows installation was found, you can run:
sudo update-grub

Note that step 2 is just for your convenience. You could just mount the Windows partition and then run update-grub .



If the os-prober method above doesn’t work try adding a custom grub menu entry.

First two steps are for finding your <UUID> .

  1. Run lsblk and find the name of the row with /boot/efi

Example output (here the answer is sda2) :

lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda           8:0    0   477G  0 disk 
├─sda1        8:1    0   450M  0 part 
├─sda2        8:2    0   100M  0 part /boot/efi
├─sda3        8:3    0    16M  0 part 
├─sda4        8:4    0    47G  0 part /windows
├─sda5        8:5    0 425,6G  0 part /
└─sda6        8:6    0   3,7G  0 part [SWAP]
mmcblk0     179:0    0  14,9G  0 disk 
└─mmcblk0p1 179:1    0  14,9G  0 part
  1. Run sudo blkid /dev/sdaX where sdaX is the answer from previous step ( sda2 in my case) .

Example output (here the answer is 58E4-427D) :

/dev/sda2: UUID="58E4-427D" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="b81727be-ba90-5f8c-ab98-d3ec67778b7d"
  1. Add the following at the end of the file /etc/grub.d/40_custom :
menuentry "Windows 10" {  
     insmod ntfs  
     set root='(hd0,1)'  
     search --no-floppy --fs-uuid --set <UUID>
     chainloader +1  
}
  1. Run sudo update-grub and reboot.

I downloaded latest version 4.9 but I’m facing same issue.

Dual boot not showing its always open the window 10

it may be the bios problem as well
have you installed on uefi or legacy system?

Same problem! I just installed parrot os 4.9, and installed grub at /dev/sda, but it doesn`t show GRUB, it goes to windows, or (if I change the boot settings) it says there are no boot options.