Nouveau drivers not setting resolution properly

Briefly describe your issue below:
So after a while of playing around my install of Parrot OS (trying out programs and whatnot), I wanted to install NVIDIA drivers. I decided to try both drivers out, and got quite mixed results. (I also followed this guide The proprietary driver would just not lead me to the Parrot login screen, and the Nouveau driver would leave me with a broken resolution of 1024x768 instead of 1680x1050. The Bumblebee daemon also complained about how it couldn’t find any integrated GPUs, either AMD, Intel or NVIDIA. Primus would atleast work sometimes, using primusrun COMMAND.

What version of Parrot are you running?
Parrot Security OS 4.9 KDE

What method did you use to install Parrot?
The “Install Parrot” option once booted into Live mode (i forgot the program’s name)

Configured to multiboot with other systems?
No, currently only Parrot OS on the hard drive

List your hardware specs to include make, model and firmware (when applicable):
Processors: 4 x Intel Core i5-4590 CPU @ 3.30 GHz
Memory: 7.7 GiB of RAM
GPU: NVIDIA GeForce 210

If there are any similar issues or solutions, link to them below:
I have went through countless web pages I don’t even know which one to link here.

If there are any error messages or relevant logs, post them below:
┌─[✗]─[atlas@parrot-thinkcentre]─[~]
└──╼ $bumblebeed --verbose
[ 1002.270622] [INFO]No Intel video card found, testing for system with an AMD APU.
[ 1002.271057] [INFO]No Intel/AMD video card found, testing for dual-nvidia system.
[ 1002.271075] [ERROR]No integrated video card found, quitting.

(this is my /etc/bumblebee/xorg.conf.nouveau)
Section "ServerLayout"
Identifier "Layout0"
Option "AutoAddDevices" "false"
Option "AutoAddGPU" "false"
EndSection

Section "Device"
Identifier "DiscreteNvidia"
Driver "nouveau"
BusID "PCI:01:00:0"
# If the X server does not automatically detect your VGA device,
# you can manually set it here.
# To get the BusID prop, run lspci | egrep 'VGA|3D' and input the data
# as you see in the commented example.
# This Setting is needed on Ubuntu 13.04.
# BusID "PCI:01:00:0"

EndSection