Nvidia Graphics Card issue

Briefly describe your issue below:
I was following this documentation(https://docs.parrotlinux.org/info/gpu-drivers/) for installing proprietary Nvidia driver.
Issue: When I had test run with optirun glxgears I had no errors and it worked but when I followed whole documentation(yes I did create those files and appended the content that instructed) and reboot the system then I ran optirun glxgears I got this error.

 ____ $optirun -vv glxgears
[ 1356.734285] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 1356.734992] [DEBUG]optirun version 3.2.1 starting...
[ 1356.734997] [DEBUG]Active configuration:
[ 1356.734999] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 1356.735001] [DEBUG] X display: :8
[ 1356.735003] [DEBUG] LD_LIBRARY_PATH: /usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/x86_64-linux-gnu:/usr/lib/i386-linux-gnu
[ 1356.735005] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 1356.735007] [DEBUG] Accel/display bridge: auto
[ 1356.735009] [DEBUG] VGL Compression: proxy
[ 1356.735011] [DEBUG] VGLrun extra options: 
[ 1356.735013] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[ 1356.735099] [DEBUG]Using auto-detected bridge primus
[ 1356.735306] [INFO]Response: No - error: Could not enable discrete graphics card

[ 1356.735313] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card

[ 1356.735318] [DEBUG]Socket closed.
[ 1356.735347] [ERROR]Aborting because fallback start is disabled.
[ 1356.735351] [DEBUG]Killing all remaining processes.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

Its fresh install of parrot and up to date.
Linux parrot 5.7.0-2parrot2-amd64 #1 SMP Debian 5.7.10-1parrot2 (2020-07-31) x86_64 GNU/Linux

If there are any error messages or relevant logs, post them below:

____ $sudo dmesg | grep bbswitch
[   41.551342] bbswitch: version 0.8
[   41.551353] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[   41.551367] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[   41.551603] bbswitch: detected an Optimus _DSM function
[   41.551807] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on
[   41.553569] bbswitch: disabling discrete graphics
[  352.141180] bbswitch: enabling discrete graphics
[  930.208956] bbswitch: enabling discrete graphics
[ 1225.390955] bbswitch: enabling discrete graphics
[ 1350.309887] bbswitch: enabling discrete graphics
[ 1354.342766] bbswitch: enabling discrete graphics
[ 1356.747766] bbswitch: enabling discrete graphics
[ 2167.234057] bbswitch: enabling discrete graphics
[ 2186.187844] bbswitch: enabling discrete graphics
[ 2405.406211] bbswitch: enabling discrete graphics

.

   ______$ lspci -v                                                                                                                                                                                            
            00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile) (prog-if 00 [VGA controller])                                                                                  
                    DeviceName: Onboard - Video                                                                                                                                                           
                    Subsystem: Dell UHD Graphics 630 (Mobile)                                                                                                                                             
                    Flags: bus master, fast devsel, latency 0, IRQ 127, IOMMU group 2                                                                                                                     
                    Memory at a2000000 (64-bit, non-prefetchable) [size=16M]                                                                                                                              
                    Memory at 80000000 (64-bit, prefetchable) [size=256M]                                                                                                                                 
                    I/O ports at 5000 [size=64]                                                                                                                                                           
                    Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]                                                                                                                            
                    Capabilities: <access denied>                                                                                                                                                         
                    Kernel driver in use: i915                                                                                                                                                            
                    Kernel modules: i915

.

______$ lspci -v 

01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev ff) (prog-if ff)
        !!! Unknown header type 7f
        Kernel modules: nvidia

what is the oputput of optimus-manager --status ?
if it shows Current GPU mode : intel then try optimus-manager --switch nvidia

see this, and this for more information.

Now it’s working perfectly.
I dont know but I uninstalled packages, removed files I created from documentation and I did followed whole documentation again.
I guess when I installed them on first time I remember I had some nvidia related updates… after updating I did “lspci -v” and I was getting following error(As you can see I already posted it)

______$ lspci -v 

01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev ff) (prog-if ff)
        !!! Unknown header type 7f
        Kernel modules: nvidia

maybe that broke something after updating.

But now its working. Thanks for replying again !!