Nvidia not working after update

Briefly describe your issue below:
My nvidia driver is not working after update to 410 version form 390.

What version of Parrot are you running? (include version, edition, and architecture)
Linux parrot 4.19.0-parrot1-20t-amd64 #1 SMP Parrot 4.19.20-2parrot1.20t (2019-03-09) x86_64 GNU/Linux

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
Dmesg says:

bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    6.663350] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[    6.663360] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20180810/nsarguments-66)
[    6.663555] bbswitch: detected an Optimus _DSM function
[    6.663568] pci 0000:01:00.0: enabling device (0000 -> 0003)
[    6.663636] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on
[    6.664309] bbswitch: disabling discrete graphics
Apr 10 15:57:31 parrot bumblebeed[955]: modprobe: ERROR: could not insert 'nvidia_current': Exec format error
Apr 10 15:57:31 parrot bumblebeed[955]: libkmod: ERROR ../libkmod/libkmod-module.c:979 command_do: Error running install command for nvidia
Apr 10 15:57:31 parrot bumblebeed[955]: [10598.228296] [ERROR]Could not load GPU driver
Apr 10 15:57:31 parrot kernel: nvidia: disagrees about version of symbol module_layout
optirun -vv glxinfo
[10710.374212] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[10710.374541] [DEBUG]optirun version 3.2.1 starting...
[10710.374547] [DEBUG]Active configuration:
[10710.374549] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[10710.374551] [DEBUG] X display: :8
[10710.374553] [DEBUG] LD_LIBRARY_PATH: /usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
[10710.374555] [DEBUG] Socket path: /var/run/bumblebee.socket
[10710.374556] [DEBUG] Accel/display bridge: auto
[10710.374574] [DEBUG] VGL Compression: proxy
[10710.374576] [DEBUG] VGLrun extra options: 
[10710.374577] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
[10710.374611] [DEBUG]Using auto-detected bridge virtualgl
[10710.380188] [INFO]Response: No - error: Could not load GPU driver

[10710.380198] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[10710.380200] [DEBUG]Socket closed.
[10710.380209] [ERROR]Aborting because fallback start is disabled.
[10710.380211] [DEBUG]Killing all remaining processes.


Please give me the content of

dkms status

Hi @hotwater!

bbswitch, 0.8, 4.19.0-parrot1-13t-amd64, x86_64: installed
bbswitch, 0.8, 4.19.0-parrot1-20t-amd64, x86_64: installed
broadcom-sta,, 4.19.0-parrot1-13t-amd64, x86_64: installed
broadcom-sta,, 4.19.0-parrot1-20t-amd64, x86_64: installed
nvidia-current, 410.104, 4.19.0-parrot1-20t-amd64, x86_64: installed
realtek-rtl88xxau,, 4.19.0-parrot1-20t-amd64, x86_64: installed
wireguard, 0.0.20190227, 4.19.0-parrot1-20t-amd64, x86_64: installed

It’s still unclear which kernel version do you have.

uname -r | grep $(uname -r)

If nvidia-current doesn’t pop up, then try doing next thing:

sudo dkms install nvidia-current/410.104 -k $(uname -r)

Thank you for reply,

uname -r | grep $(uname -r):

sudo dkms install nvidia-current/410.104 -k $(uname -r):
Module nvidia-current/410.104 already installed on kernel 4.19.0-parrot1-20t-amd64/x86_64

I want to revert back to 390 drivers, is here any guide how to install them after removing 410? After purge nvidia and bumblebee and apt-get install nvidia-390 it is tryoing to install 410 again

Problem solved by manually installation Nvidia.com latest drivers