Open-vm-tools causes parrot to break

If have installed the most recent version of parrot as of april 2019 on a optimus laptop using an usb and not a virtual machine with debian GTK. There are no other operating systems installed. The first thing i did after the install is running the sudo parrot-upgrade in the MATE-terminal. The update runs smoothly until reaches 72% when it installs open-vm-tools. Suddenly my laptop freezes. I push the power-button to turn my laptop off. When I start it up again, parrot is completely broken. (as shown in the image).blob:file:///865821c3-0456-43a3-94ce-98c43ea9fbb5 Why does this happen and how do I fix it. I think parrot has a bug. Does anyone else have this problem and I how do I fix it?!

I used rufus to burn Parrot on a different laptop, settings shown in the image
version of parrot: Parrot-security-4.5.1_amd64

Theres nothing wrong with open-vm-tools if the laptop seems frozen give it a while it usually just needs time and a lot resources, this may happen for some packages.
2. If for any reason an apt process doesnt finish use dpkg --configure -a will finish configuring and installing those pkg’s that have been downloaded

I have tested parrot on a different laptop. Same thing happened. It took a while and it didn’t unfreeze. My only option was to turn my laptop and the kernel broke again. I also tested this in a vm. Same thing happened. The only conclusion is that is caused by parrot, probably a bug and this needs to be resolved. Its no use trying dpkg --configure -a, because parrot completely freezes.

Thank you for your input.

I have a solution that bypasses the open-vm-tools installation. It does not solve the issue. However, it does prevent open-vm-tools from installing and thus prevents parrot from breaking.

Here is what i did:

sudo apt-mark hold open-vm-tools
sudo apt update && sudo apt upgrade -y reboot

I want to use virtual machines in the future, so I need to install open-vm-tools. However, until they fixed open-vm-tools, I will refrain myself from doing so.

Hi @Crystal_Meth,

Have you tried running sudo parrot-upgrade after you held back the open-vm-tools package? I thought I had some issues when installing a while back as well. My installation would appear to freeze when updating the man-db, but I let it sit for a while and eveything installed without issue.

I tried, however the same thing happenend. I am going to try your solution in a virtual machine. Maybe it is fixed now. I will notify you as soon as I am done. I will test this on a different laptop.

I think the issue might be related to the way you created the live media. Parrot recommends using Etcher to create the USB media. If you have time, I would suggest using Etcher to recreate the USB media. I had very similar issues with the installation freezing when using dd to create the USB media with Parrot 4.5.1.

I used rufus on windows 10 to create USB-installation media. I have tested the installation of the open-vm-tools before on a virtual machine with parrot OS. The same thing happened. I do not think for that reason that the usb-media creator is the cause of the issue. Also it is only the open-vm-tools package that is problamatic, everything else works fine. Thank you for your input.

Based on what you’ve described, it does seem related to the open-vm-tools package and not the installation. If you have time though, it might be worth a shot to create the USB media with Etcher. It’s free and available for Windows machines. Good luck though, if you find a solution, please let the community know. Thanks!

I will give your solution a shot! Thank you. I shall notify if it worked.

I used sudo parrot-upgrade in a virtual machine using parrot os. It worked!
After that test I ran the following commands on my parrot os boot:

sudo apt-mark unhold open-vm-tools
sudo parrot-upgrade

It installed perfectly without freezing!

Glad you were able to get everything up and running!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.