OpenVAS not working after upgrade.

Hello,
After upgrade ParretSec, OpenVAS couldn’t run:

ERROR: The default postgresql version is not 12 required by libgvmd
Error: Use pg_upgradecluster to update your postgres cluster

Is something wrong?

Thank you.

1 Like

OpenVAS is changing the name, the new command gvm will replace all openvas commands.
Since Kali Rolling updated repository, we now should use gvm instead of openvas commands
So…
sudo apt install gvm -y
or
sudo gvm-setup
or
sudo gvm-feed-update
or
sudo gvm-start

1 Like

The output of commands are:

$ sudo apt install gvm -y
Reading package lists... Done
Building dependency tree       
Reading state information... Done
gvm is already the newest version (11.0.5+kali1).
gvm set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up faraday (3.12-0kali1) ...
2020-10-08T12:38:40-0400 - faraday.faraday_plugins.plugins.manager - INFO {MainThread} [manager.py:152 - _load_plugins()]  Loading Native Plugins...
2020-10-08T12:38:41-0400 - faraday.faraday_plugins.plugins.manager - INFO {MainThread} [manager.py:203 - _load_plugins()]  68 plugins loaded
INFO  [alembic.runtime.migration] Context impl PostgresqlImpl.
INFO  [alembic.runtime.migration] Will assume transactional DDL.
INFO  [alembic.runtime.migration] Running upgrade  -> e61afb450465, Add custom fields
2020-10-08T12:38:41-0400 - faraday.manage - ERROR {MainThread} [manage.py:263 - migrate()]  Migration Error: (psycopg2.errors.UndefinedTable) relation "vulnerability" does not exist

[SQL: ALTER TABLE vulnerability ADD COLUMN custom_fields JSONB]
(Background on this error at: http://sqlalche.me/e/13/f405)
Migration failed! (psycopg2.errors.UndefinedTable) relation "vulnerability" does
 not exist

[SQL: ALTER TABLE vulnerability ADD COLUMN custom_fields JSONB]
(Background on this error at: http://sqlalche.me/e/13/f405)
dpkg: error processing package faraday (--configure):
 installed faraday package post-installation script subprocess returned error ex
it status 1
dpkg: dependency problems prevent configuration of python-faraday:
 python-faraday depends on faraday; however:
  Package faraday is not configured yet.

dpkg: error processing package python-faraday (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 faraday
 python-faraday
Scanning application launchers
Removing duplicate launchers from Debian
Launchers are updated
E: Sub-process /usr/bin/dpkg returned an error code (1)

And:

$sudo gvm-setup
ERROR: The default postgresql version is not 12 required by libgvmd
Error: Use pg_upgradecluster to update your postgres cluster