Pakages can be upgraded

i ran apt-get update but insted of updating it said 71 pakages can be upgraded why dosen’t it update them by command

i used to run this command before and it has been working before. i broke my previous parrot os so i installed it again and now it is not working and parrot-upgrade takes a lot of time like almost a day
so can anyone one tell me how to make it work again.

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
using iso from dvd

Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:
other communites say use apt-get upgrade but thats kinda prohabited in parrot thats how i broke my previous any alternatives?
If there are any error messages or relevant logs, post them below:
no. before it gave some kinda error of dpkg i don’t remember that and i deleted all the things in info of dpkg folder and now it says this.

So apt-get update doesnt upgrade packages, it just checks what new versions are available from the repo.
From the man page (

Used to re-synchronize the package index files from their sources. The indexes of available packages are fetched from the location (s) specified in /etc/apt/ sources.list (5). An update should always be performed before an upgrade or dist-upgrade.

The command you used before was probably apt-get upgrade. But you are right in saying you shouldnt use it.

If you want to update your system, then use sudo parrot-upgrade.

It might be worth looking at why parrot-upgrade takes so long. Obviously the more frequently you update the less packages you will have to upgrade, so maybe just try updating more often.

1 Like

no before i used apt-get update for updating the system and apt-get upgrade .
but if parrot-update is the only way i will use that from now on.
thanks for reply.

1 Like

do sudo apt full-upgrade. parrot-upgrade is a shorter and safer way to do full-upgrade

└──╼ $cat `which parrot-upgrade`
set -e
apt update || echo failed to update index lists
dpkg --configure -a || echo failed to fix interrupted upgrades
apt --fix-broken --fix-missing install || echo failed to fix conflicts
apt -y --allow-downgrades --fix-broken --fix-missing dist-upgrade

In my honest opinion.
The command


doesn’t exist,

Thanks for the honest opinion but the issue has been solved

sudo apt-get update
sudo apt-get full-upgrade

It is


Uppercase, lowercase syntax my friend.