Parrot 3.11 development discussions

parrot

(n0one) #42

i need to get a copy of this it looks incrediable


(dmknght) #43

No no. For me, the top menu (applications) is similar bottom so if we change bottom menu to mate main menu (actually i am using) it would be cooler.


(dmknght) #44
  1. I just tested and anonsurft started and stopped tor automatically (somehow it did not for me at last week). Many thanks for that.
  2. Is there anyway to use libsodium from gem repo instead of Debian version (just asking. I think using Debian version is a better choice, isn’t it?)

(dmknght) #45

Metasploit team has removed libsodium dependency. They said they removed and waited for newer version of libsodium.

https://github.com/rapid7/metasploit-framework/pull/9314


#46

I used “msfdb init” after install, and i don’t have any errors like that on Parrot 3.11 i never saw that problem before either. Screenshot below of Armitage, MSFvenom and MSFconsole running fine.

Summary

I would like Atom to be back on Parrot though…


(dmknght) #47

what is your libsodium version? I upgraded my system and libsodium upgraded to 23 (libsodium-23) automatically. Then metasploit-framework could not be used. This bug has confirmed on metasploit-framework github. Please tell me if you know any solution. My metasploit can not be used for weeks :*(


#48

How do i know the version ? I posted a link below of apt search for libsodium look at it and check if there is what you’re looking for. As for how i made it work i did nothing, it worked out of the box i think, or maybe it has to do with my “PTF” script that install external tools which i run after each installation… I will launch a clean install soon without using PTF and try to locate your problem. Create a topic in support about it though, it will be easier.

Summary


(Lorenzo "Palinuro" Faletra) #49

yesterday night i have prepared a new metasploit-framework version where the libsodium dependency was explicitly included


(dmknght) #50

So glad to here that. Anyway there are two more problems:

  1. A small bug about edb-debugger. Its plugins path is /usr/lib/x86_64-linux-gnu/edb/ (for amd64 package) but program path set to /usr/lib/edb. It means edb-debugger will show error message (something about missing plugins) and quit. I think this application needs to be fixed.
  2. My notification area does not show background applications. I think it is icon bug (maybe?). I did google search and i saw mate devs said about gpu bugs. My problem came from Parrot 3.10, as i remember. Applications (don’t show icon on notification area): fcitx (keyboard), qbittorrent, mega sync (randomly). However skype’s icon works well. If i am only one who is having this, please tell me so i will debug it.

#51

For 1. Use “Alt+F2”(by default) to open the application launcher, and type “edb” inside, you will notice there is a shortcut for “edb-debugger” and “edb”, try running edb instead of edb-debugger.

For 2. I can’t really tell as i don’t install applications, but every tools pre-installed on Parrot gives me notifications about events in background.


(Lorenzo "Palinuro" Faletra) #52

parrot 3.11 works now :slight_smile:

the final iso files will start to be delivered to the mirror this night


(Lorenzo "Palinuro" Faletra) #53

iso files are now available

please go to https://archive.parrotsec.org/parrot/iso/3.11 and seed the torrents to help us


(AresX) #54

What is the theme name ?


(Mohamed Salama) #55

Just change the properties of the panels background to be Transparet :slight_smile: and have fun :rose:


(Lorenzo "Palinuro" Faletra) #56

i think many people would not like it and someone may not be able to run parrot anymore on their computer because of missing hardware support

we prefer to give users something that works and does not look ugly, and then leave them all the freedom to “uglify” their parrot environment as they want :slight_smile:


#57

Have u found a solution to the metasploit problem bc I haven’t been able to


#58

I am having the same error with libsodium


(dmknght) #59

what do you mean? upgrade you system + metasploit. Libsodium has been fixed.


(dmknght) #60

firejail process does not stop after closing process.
For example: if i open firefox, then close firefox, a process /usr/bin/firejail /usr/bin/firefox is still there. It is kinda like dummy process. Running multiple applications can make firejail leak user’s memory. I am using latest upgrade.


#61

Is it also doing that on other processes ? Because internet browsers have offline data, which is maybe why firejail keep a process of it even after closing. I might be wrong, but check if it’s same for others.

I tried, and only Firefox has an after-process, one thing i find weird is that running Owasp-Mantra-ff does not keep after-process, even though it is also an internet browser. But anyway you can be sure there’s no memory leak.