Parrot 4.0 beta testers


(Lorenzo "Palinuro" Faletra) #1

do you want to be a beta-tester of parrot 4.0?

download the latest testing releases from https://cdimage.parrotsec.org/parrot/iso/testing

try them and send your full report to [email protected] or paste it as a comment below


Has 4.0 been released yet?
(Manuel Hernandez) #3

No. The beta build is loaded with the most recent changes, as far as we know these changes are related mainly to the work of Parrot as individual distribution (built-in apps), other package updates are always avaible as they come.

Until the next release comes this is what we have. If you take a look over the development discussions there is a large (and increasing) list of changes and some of them are kind of critical, it wouldn’t be right just to make these changes available along the normal upgrades, that’s why the beta testing exists.

Parrot is a rolling release distribution, which means there shouldn’t be too much issue with upgrading from 3.x to 4.0, but a fresh install is always recommended.


#4

the installation is working fine on home and security build, and i noticed less ram usage i think, went from 700mb to 600 on desktop when idle(security version)

@palinuro on home build, the vim is real bad and will mess up any text file one touch(eg; try deleting key on a text file you will understand) , installing the package vim-gnome will fix that issue and add all the additionnal features like multiple clipboards etc

edit; also gnuradio companion wont work anymore, unless the user setup the correct environment, Screenshot%20at%202018-04-30%2019-18-40

and i dont use kayak, but it wont run either, it gets stuck at ‘initializing’ then exit (i tell you that because kayak is from the parrot repository)

last thing maybe a bit off topic, on the security build i have multiples port always open (smb), on my setup using the home build, all 65k ports are closed, what are the use of the open port on the security release ?


GNURadio and GQRX doesn't start properly
(Mateus Veras) #5

I can not download the ISO from the parrot 4.0, when it arrives at 2.7 GB do not want to download, I am from Brazil


(dmknght) #6

I got error message about systemd appamor in live mode, and shutdown in live mode gave me some error + it could not be stopped (tested in Virtualbox 5.20 debian 9). Other stuffs were good. Parrot ran smoothly in my Vbox and i did not know difference between old and new systemd :smiley:


(dmknght) #7

I installed Parrot 4.0 alpha in a Asus laptop (my friend’s). Parrot was unable to shut down. I had black screen, not msg (likes watchdog stop) or anything. I installed Parrot home 3.11 and it worked fine.


#8

Hi fuckers hackers!

Just download 4.0 alpha - sorry for late. A few things what im already find (testing HOME!)

  1. Anonsurf dont working through menu, because all command except anonsurf ip/anonsurf mac working with menuxexecg (gksu). By the way - no more gksu support from debian.

From terminal all comands work fine with sudo - even anonsurf change ^^

But one little dirty thing - you make function anonsurf changemac - but no macchanger preinstalled in Home :smiley:

  1. System monitor plugin - Netspeed - a little bit buggy at 5000. Change this to 1000 and bugs go away.

  2. Rknunter cant check files - mb less strict apparmor/firejail permissions?

┌─[[email protected]]─[~]
└──╼ $sudo rkhunter --check
[sudo] password for user:
[ Rootkit Hunter version 1.4.6 ]

Checking system commands…

Performing ‘strings’ command checks
Checking ‘strings’ command [ OK ]

Performing ‘shared libraries’ checks
Checking for preloading variables [ None found ]
Checking for preloaded libraries [ None found ]
Checking LD_LIBRARY_PATH variable [ Not found ]

Performing file properties checks
Checking for prerequisites [ OK ]
/usr/local/bin/less [ Warning ]
/usr/local/bin/ping [ Warning ]
/usr/local/bin/ssh [ Warning ]
/usr/local/bin/strings [ Warning ]
/usr/local/bin/wget [ Warning ]
/usr/sbin/adduser [ OK ]

/usr/bin/strings: ‘/etc/systemd/system/final.target.wants/snapd.system-shutdown.service’: No such file
/usr/bin/strings: ‘/etc/systemd/system/open-vm-tools.service.requires/vgauth.service’: No such file
/usr/bin/strings: ‘/etc/systemd/system/graphical.target.wants/accounts-daemon.service’: No such file
/usr/bin/strings: ‘/etc/systemd/system/graphical.target.wants/udisks2.service’: No such file
/usr/bin/strings: ‘/etc/systemd/system/dbus-org.freedesktop.nm-dispatcher.service’: No such file
/usr/bin/strings: ‘/etc/systemd/system/timers.target.wants/snapd.snap-repair.timer’: No such file
/usr/bin/strings: ‘/etc/systemd/system/timers.target.wants/apt-daily.timer’: No such file
/usr/bin/strings: ‘/etc/systemd/system/timers.target.wants/apt-daily-upgrade.timer’: No such file
/usr/bin/strings: ‘/etc/systemd/system/timers.target.wants/snapd.refresh.timer’: No such file
/usr/bin/strings: ‘/etc/systemd/system/getty.target.wants/[email protected]’: No such file
/usr/bin/strings: ‘/etc/systemd/system/syslog.service’: No such file
/usr/bin/strings: ‘/etc/systemd/system/dbus-fi.w1.wpa_supplicant1.service’: No such file

And thats warnings - except lwp request its not good guys.

  1. Lynis index of hardening system - only a 60 pts. WarTech CR1ME Linux have 77-84 in a different versions. Do some thing! )

ILL BE BACK


#9

anonsurf is working fine, but if one does not use it from terminal, using the change node wont work it will just hang, in terminal it works though

i got same error on home build about rkhunter, and running it directly from ‘/usr/bin’ will still give same errors, probably firejail


(dmknght) #11

This is error message when i shut Parrot 4.0a down. I am thinking new systemd is having problem.


#12

Hi everyone! The good news!

  1. Firefox now closes on anonsurf init function
  2. Onioncircuits now working from user accounts
  3. Bug with zomby icons of unmounted MTP devices fixed as well

p.s. y u dont use 2>/dev/null after zenity strings? dat warnings so annoying!
p.p.s no more i2p in anonsurf? so sad.

to those who thinks i2p to slow :

  1. change java wrapper config - max memory string from 128 to 256
  2. x2 bandwith
  3. 3 > 4 all types of tunnels quantity
  4. disable reduce on idle
  5. network status - ok or at least firewalled

DONT SHUT DOWN ROUTER 24-72 HRS FOR FUCK SAKE!

and then you be are fully integrated i2p god father ^^

Lorenzo - parrot home have all fucking stuff for common user. best lite distro today. add telegram-desktop, Bridges to torrc and show desktop icon to pannel - and you are fucking king ^^


#13

sr0 - usb modem or something llike that? if yes - problem is usb-modeswitch - that faggot detect usb modem as usb storage at same time on boot or poweroff. u can simply fix that thing - bios - usb setting - usb storage - change auto to force hdd.


(dmknght) #14

It was running inside Virtualbox, and as i remember, Parrot 3.11 does not have this issue. So this could be a problem.


#15

i2p is not inside the anonsurf menu, but its still installed by default on both home and security, you can run it manually i2prouter


(517hum 54nd33p4) #16

@palinuro , are you remove system d?


#17

i know. i mean no i2p functions inside anonsurf.sh


#18

u run vm on stick?


(Lorenzo "Palinuro" Faletra) #19

thanks for all your feedback

i have just released an updated iso image (4.0-beta) replaci g the previous alpha release)

i’ll also take in consideration all your feedbacks for the next (hopefully final) release

pleaae continue to provide your feedback on the new beta release as many bugs were closed but new ones may be introduced

http://cdimage.archive.parrotsec.org/parrot/iso/testing

for people with download issues: adding .mirrorlist to the end of a file name will give you the full mirrors list where that file can be downloaded

i.e.
http://cdimage.parrotsec.org/parrot/iso/testing/Parrot-security-4.0-beta_amd64.iso.mirrorlist


Parrot 4.0 development discussions
#20

here’s a problem i have since yesterday on 4.0 alpha(will install beta later), my cpu usage goes very high whenever i use something inside a terminal, i noticed it too late and my laptop couldnt be touched in some part, it was very hot
edit ; its home version

never had that on 3.11, and no i dont think its sqlmap, it happens with anything else

the first screenshot i had no other bash opened except htop so i dont understand where it comes from, it state its opened since 3hours

the two others screenshot are from today it happened again while i used sqlmap, but tried other processes and it did the same




(Lorenzo "Palinuro" Faletra) #21

noticed the same thing, and in my case it was caused by mate-inhibit-applet, which is the tiny button on the bottom right of the screen which disables the auto suspension of the system

i’ll try to fix it for the next release


(Lorenzo "Palinuro" Faletra) #22

i also spotted openvas spawning some useless services at boot by default and disable that behavior

hope new debian updates would fix other minor bugs (i.e. mate bugs etc)

p.s.
i fixed kayak