Parrot 4.10 Bug Report

Place for reporting bugs in Parrot 4.10
Please use the following template:

## If you are having an issue, please follow this

**There are many kinds of issues: OS, software, server, … So you must know:**

* Server issues will be fixed after report and we verify the problem. There will be no update patch for you. It is server side.
* 3rd party software / packages can’t be fixed by us. If we can spot the bug and have the fix, we will create merge request to original source and wait for their official version.
* Life is hard. For bug/ issue, please make sure your topic is only one. Dont make developers be terrorists.
* This is a rolling distro. Bugs and issues are expected. We recommend you have basic linux knowledge to deal with your system, so
**Usually we don’t support issues that user faces by using his system in a wrong way. If you are new to Linux, make sure you didn’t make any mistake:**

1. Basic Linux: http://linux-training.be/
2. How to not break Debian system: https://wiki.debian.org/DontBreakDebian or https://averagelinuxuser.com/how-not-to-break-your-debian-system/
3. If you are having some questions, your answers might be in here: https://wiki.debian.org/FAQsFromDebianUser
4. Your issue might be solved before (StackOverflow is a temple), try this: https://www.searchenginejournal.com/search-engines/answering-questions/

### 1. Your Parrot information

* OS version: run `cat /etc/*release`
`     Copy output here     `
* Kernel version: run `uname -a`
`      Copy output here      `

*Or if you can’t do it, please tell us ISO version you downloaded.*

** ISO information **

```
Version: 4.9
Desktop Environment: Mate
Edition: Home
```

### 2. If you have this problem after fresh installation:

1. How did you create USB bootable?
  * Software was used to make USB
  * Steps of making USB bootable
2. How did you install OS?
  * Debian installer or Calamares installer?

### 3. If your hardware doesn’t work: wifi doesn’t show, graphic issue:

**Hardware information**

```
- Your device name or output of `lspci`
```
    Copy output here
```
- Did you try searching info about this issue on search engine? Please write **No** or any URL to this issue bellow
```

### 4. How did you get this error? Are there any steps to procedure it?

```
1. I installed this
2. I ran this new software
3. It shows me this or that
```

### 5. Error log or screenshot

** Insert error log and screenshot here**

### 6. If you have any idea or suggestion about this issue please tell us

** Your information **

## If you are having suggestion for our OS, please write it bellow

### 1. Current Parrot version and Parrot version you want it has

### 2. Its section and how it affects our system

* Pentesting / Forensic / Malware hunting / Privacy protection / …
* It is: AppArmor profile / software / system service / kernel module…
* when user runs this / start that, it can do…

### 3. Any other information about this idea
3 Likes

Known problems:

  • Konsole error in KDE. Temp fix by set custom path of terminal.
  • Mate DE: caja process (could be session, not file manager) took > 500mb ram
  • XFCE: thunar could take 700mb ram and very slow start. This could be using dual DE with mate
  • A bug that Torbrowser-launcher can’t verify signature. Bug topic and fix method is in here "Signature Verification Failed" in Tor Browser Launcher (There is no other method to fix for now).
  • A bug that Torbrowser-launcher can’t start. The package gnupg2 is required. Fix: sudo apt install gnupg2
  • xfce-screensaver can’t type password. Bug issue is on the repository. We should wait for patch.
2 Likes

Both in Security and Home edition (Mate)
in Menu > Internet, there are both Element and Ricochet, which serves for the same purpose.

The problem of xfce-screensaver could be both light-locker and xfce-screensaver was installed (light-locker was installed silently)
The method COULD fix the problem (it is under testing in my VM)

  1. Uninstall light-locker
    sudo apt remove light-locker
  2. Remove the startup launcher
    sudo rm /etc/xdg/autostart/light-locker.desktop
    This steps can be applied for xscreensaver (which isn’t installed)
2 Likes

Thank you very much!
That is more than I learned in school! LOL!

I read that on the site but didn’t know WHERE to click the LINK / URL/ Button to add the bugs! OPPS!

SO if I get more time, fighting with this X windose laptop, I’ll look more for the actual link to add the bugs!

Again thank you, tessy, for your valuable time!

A missing categories icon bug is happening on Mate DE. It only happen when user change system language. It is widely bug because Ubuntu is having this problem too.


Update: this issue is closed. Our latest mate is 1.24.1

Bug:
When running Parrot XFCE it appears that two different login screen are installed.

The default Parrot Login (Also used in Parrot Mate) works fine,
but once the password has been entered causes login2 (controlled by XFCE settings) to appear as well.
This second screen does not accept any keyboard input (but is otherwise responsive), making it impossible to log in.

When is the bug observed:
This issue happens when the screensaver activates, causing the password prompt to reappear. It does not happen during login.

How to fix the bug:
It is possible to fix this issue by disabling the second login screen using xfce settings (screensaver tab).
The default password prompt still appears though, ignoring the settings.
You could likely also uninstall one of the screens, though i have not tested that.

Are you talking about login screen or screensaver?
If the problem is screensaver, the solution is remove light-locker. It was installed by debian package as dependencies.

I never tested this any further, since the fix is so simple.
However, a quick apt search shows that both the mate and xfce4 screensaver are installed,
so that’s likely the problem.

I will try to remove the mate one and re-enable the xfce screensaver,
to test if the issue still occurs.

1 Like

Yes, the issue does still occur. The xfce screensaver appears to be entirely broken.
This happens on both my notebook and on virt-manager (Live USB), so it’s definitely easy to spot.

1 Like

The tor command, and by extension anonsurf,
fail to start when running parrot using openrc / sysvinit / both.

The issue appears to be the following line:
Sep 12 23:20:34.788 [warn] Could not bind to 127.0.0.1:53: Permission denied

You can start it by disabling tor dns resolving, with the obvious security implications.
Doing so will not allow anonsurf to start however, so something else is still going on.

It appears that the service anonsurfd is missing, though i do not why that is.

I tried to start the service using the openrc service starter (rc-service)
This failed with the following output; rc-service: Permission denied

strace show the following line:
ppoll([{fd=-1}, {fd=3, events=POLLIN}], 2, NULL, NULL, 8 * rc-service: Permission denied

Interesting: The command service no longer finds anonsurfd.
Anonsurf likely calls service to start anonsurfd, but since service now returns “not known” fails.
Systemctl meanwhile happily finds anonsurfd, yet fails to start it.

I did some more tinkering:
Replacing the 3 /usr/sbin/service commandos of anonsurf does remove the terminal warning,
yet the command still fails, likely because systemctl still fails to start anonsurfd.
I also made sure that anondaemon runs correctly, or at least does not throw terminal warnings.

Lacking any further ideas on how to help solving this. I simply don’t know enough about services.

1 Like

xfce iso doesn’t have mate screensaver or anything belong to Mate DE except the mate-system-monitor because xfce-task-manager sucks.

1 Like

Desktop: xfce
Bug: system install firefox-esr while firefox is in the system when install full pentest tools parrot-tools-all.
Possible reason: meta package.
And other problem is lightdm-settings.desktop is displaying as Login Window and idk should i remove / exclude it on xfce iso. I didn’t test other versions like mate.

1 Like

There is something wrong with firefox and profile. Privacy badger and ublock doesn’t work with firefox. I have to disable and enable again.

2 Likes

True, i believe i still have it because my notebook used an experimental xfce iso,
which strangely shipped with mate by default.

I doesn’t really matter though, the issue appears even on the current xfce iso if run under virt-manager.

1 Like

IT could be beta version

As i said above, remove light-locker

1 Like

First off: The xfce iso currently lacks both engrampa and xarchiver, is that intended?

Regarding Light Locker:
Removing Light-Locker does not appear to help, unless i also have to reboot.
My test on a live USB - ram mode still gets stuck on xfce-screensaver.

Also note that my temporary workaround - restarting lightdm via
service lightdm restart
does not appear to work on that live-usb, as i failed to start it up again.

Lastly one note of interest:
Removing Light-Locker did help with my openrc -only install,
which suffered from a new bug, causing me to get stuck after unlocking.

I only saw the (lightdm?) session currently logged screen,
telling me to wait a few seconds without anything actually happening.

1 Like