Parrot 4.10 problem with lock screen

Hello, I am newb here and using parrot, but 3 days reading Parrot docs, I just installled Parrot Security MATE 4.10 but I realized there were another version KDE, then decided install it by using terminal:
apt install parrot-kde
And everything was working fine, even that command installed sddm (before that I was able to log in directly to parrot mate) and there were 3 options: plasma / mate / default-xsession

Days later decided to remove MATE environment by typing this:
apt-get remove parrot-mate
apt-get remove --auto-remove mate*

(Here the problem)
and everything was working fine but lock screen form (inputs textbox user and pass, and buttons) are not showing but wallpaper and cursor pointer and just stays like that.

Is there any way to fix it? I was thinking about “apt purge parrot-interface-common” and re install, or something like that, but I’m not sure. I really don’t want to lose my installed apps (“linset”, “fluxion”, and many modules from Wifislax), it took me a time to make those apps work :cry:

My device:

  • Lenovo Thinkpad L430 (Intel i5 3380M)
  • Ralink RT3070
  • Parrot OS 4.10 KDE (before was MATE and removed it)

Check startup application and disable any lockscreen that doesn’t belong to current DE

1 Like

I tried it but didn’t work, now I am trying to install it again but this time I want to know what are the proper ways to install and remove desktop environments by using terminal, I saw a tutorial on “Installion” website:

Uninstall parrot-mate and its dependencies (Not sure if I should use “apt-get” but “apt” as Parrot FAQ explain)

sudo apt-get remove --auto-remove parrot-mate

Purging your config/data too

sudo apt-get purge parrot-mate
or
sudo apt-get purge --auto-remove parrot-mate

Can you show me proper commands to uninstall parrot Mate and don’t mess KDE environment and packages?
Also I want to know if there is a special Parrot Doc section that explain this?

I have never tried it. As i remember, it doesn’t have this problem before.
And as far as i know, this problem happens because multiple screensaver / screen locker runs at the same time.
Try ps -aux | grep saver and ps -aux | grep locker to check processes.


I just removed KDE completely, by using terminal :

apt remove --auto-remove [package]
apt purge package --auto-remove [package]
in this order:

  • parrot-mate
  • parrot-interface-full
  • parrot-interface-common

apt autoremove
After that I was looking for dependencies but parrot was “clean” and then installed parrot-kde again and parrot-interface-full, parrot-interface-extra. At the end I read a document that parrot project leader posted and found this:

Package: parrot-interface-stub
Architecture: all
Description: stub/empty package for parrot-interface
This is a stub/empty package that, if installed, allows the removal of the default desktop environment without causing the removal of parrot-interface and parrot-interface-common

I don’t know how to use this package, but it seems it would be better use it than remove all parrot-interface* one by one. :expressionless: Do you know how to use it? (parrot-interface-stub), thanks for your time replying and your work in parrotsec.

okay the screenlocker problem is weird.
Because on xfce, it happens because the light-locker and xfce4-screensaver both runs.
For totally remove and install, i’d suggest you install parrot-mate first then remove parrot-kde.

I’ve noticed changing “Global theme” in system settings hides or disables lock screen and when you select a new theme again again, interface is not showing, but cursor pointer. There must be a code that it is doesn’t know how to handle those changes properly or those themes are not compatible, even so, those themes are in the system settings addon installer. Right now, I am using Sweet KDE theme but this time didn’t touch “Global themes”, but set it up manually, e-g.: Icons, plasma style, app style, splash screen, cursor, window style, etc.
Now lock screen and SDDM are in default settings and working perfectly, thanks for replying and your attention. :slight_smile:

1 Like

i’ve got same problem, help me