Parrot 4.11 Bug Reporting

Place for reporting bugs in Parrot 4.11
Please use the following template:

## If you are having an issue, please follow this

**There are many kinds of issues: OS, software, server, … So you must know:**

* Server issues will be fixed after report and we verify the problem. There will be no update patch for you. It is server side.
* 3rd party software / packages can’t be fixed by us. If we can spot the bug and have the fix, we will create merge request to original source and wait for their official version.
* Life is hard. For bug/ issue, please make sure your topic is only one. Dont make developers be terrorists.
* This is a rolling distro. Bugs and issues are expected. We recommend you have basic linux knowledge to deal with your system, so
**Usually we don’t support issues that user faces by using his system in a wrong way. If you are new to Linux, make sure you didn’t make any mistake:**

1. Basic Linux: http://linux-training.be/
2. How to not break Debian system: https://wiki.debian.org/DontBreakDebian or https://averagelinuxuser.com/how-not-to-break-your-debian-system/
3. If you are having some questions, your answers might be in here: https://wiki.debian.org/FAQsFromDebianUser
4. Your issue might be solved before (StackOverflow is a temple), try this: https://www.searchenginejournal.com/search-engines/answering-questions/

### 1. Your Parrot information

* OS version: run `cat /etc/*release`
`     Copy output here     `
* Kernel version: run `uname -a`
`      Copy output here      `

*Or if you can’t do it, please tell us ISO version you downloaded.*

** ISO information **

```
Version: 4.9
Desktop Environment: Mate
Edition: Home
```

### 2. If you have this problem after fresh installation:

1. How did you create USB bootable?
  * Software was used to make USB
  * Steps of making USB bootable
2. How did you install OS?
  * Debian installer or Calamares installer?

### 3. If your hardware doesn’t work: wifi doesn’t show, graphic issue:

**Hardware information**

```
- Your device name or output of `lspci`
```
    Copy output here
```
- Did you try searching info about this issue on search engine? Please write **No** or any URL to this issue bellow
```

### 4. How did you get this error? Are there any steps to procedure it?

```
1. I installed this
2. I ran this new software
3. It shows me this or that
```

### 5. Error log or screenshot

** Insert error log and screenshot here**

### 6. If you have any idea or suggestion about this issue please tell us

** Your information **

## If you are having suggestion for our OS, please write it bellow

### 1. Current Parrot version and Parrot version you want it has

### 2. Its section and how it affects our system

* Pentesting / Forensic / Malware hunting / Privacy protection / …
* It is: AppArmor profile / software / system service / kernel module…
* when user runs this / start that, it can do…

### 3. Any other information about this idea

I did a fresh install of Parrot-security-4.11_amd64.iso yesterday. When launching Synaptic, it asks for the root password, not the sudoer password. Someone on the Facebook Parrot OS (Official Group) is reporting the same issue. I had to create a password for root as the Calamares installer didn’t ask for one.

uname -a

Linux zazu 5.10.0-5parrot1-amd64 #1 SMP Debian 5.10.24-5parrot1 (2021-03-20) x86_64 GNU/Linux

cat /etc/*release

DISTRIB_ID=Parrot
DISTRIB_RELEASE=4.11
DISTRIB_CODENAME=rolling
DISTRIB_DESCRIPTION=“Parrot OS 4.11”
PRETTY_NAME=“Parrot OS 4.11”
NAME=“Parrot OS”
ID=parrot
ID_LIKE=debian
VERSION=“4.11”
VERSION_ID=“4.11”

Parrot Security 4.11 is installed on a UEFI bootable USB thumbdrive (LUKS encrypted) running on the latest VirtualBox for Windows.

Thank you for your report. Unfortunately we don’t support this package directly so we don’t have any solution for now. And i don’t see any new update since Nov 2020 (from apt changelog) which is kinda weird. I think the problem could be polkit’s error during fresh install.
More about this problem: i don’t think it happens for synaptic only but other programs that uses polkit (disk mounting from file manager), … We’ll fix this problem as soon as possible

2 Likes

Hello, i’m getting an error during the istallation of Parrot OS security on a virtualBox (debian x64) based.
At first it boots normally into the installation, but then after it asks for the keyboard layout it gets stuck on: “Parrot OS : No Device for installation media was detected” and i can’t manage to go past this message.
I’ve searched for a while on the internet but i can’t manage to find a solution.
I’ve also tryed this command in the shell: mount -t vfat /dev/sdb1 /cdrom , but it gave an error.

I’ve already tryed to re-download the ISO from the official website.

P.S: I forgot to say that I’ve also tryed to install the home version of Parrot OS, but it gave the same error as the security one.
I’ve also tryed to unistall and reinstall VirtualBox in both disks. I have 2 drives… thought i could’ve been some error due to it not being in the main drive, but I was wrong.

3 Likes

I have this same issue trying to install the KDE edition of security on vmware workstation 16. I’ve also tried on vmware workstation 14. Tried downloading installation media via torrent and direct download. I also tried the same command as the person above but with the type iso9660. Maybe these outputs will help some, it looks like it doesn’t see the disk:

2 Likes

First bug solution: After installation, the /etc/hosts is empty which must be problem of calamares installer
I’m going to test and check Debian installer to see the problem of disk mounting
Update: could be this
image
Update 2: Problem is fixed on source code. we could release next version to fix issues

1 Like

Second bug: The ask for root password problem which related to polkit directly


The output error of debian installer

Have you guy’s already pushed an update?
btw this is the error it gives I think.
Capture

1 Like

Parrot OS 4.11 - all editions: boot Parrot ISO via grub loopback function don’t work.

We have a loopback.cfg file on the Parrot OS ISO image. It loads the configuration from the grub.cfg file. Unfortunately, it does not contain the variables needed to boot the system - Parrot OS does not boot.

I suggest adding the following entries to the grub.cfg file:

if [ -n "${iso_path}" ]; then
    isoboot="findiso=${iso_path}"
    export isoboot
fi

# Live boot
menuentry "Live" --class iso {
        set gfxpayload=keep
        linux /live/vmlinuz boot=live hostname=parrot quiet splash components noautomount noeject $isoboot
        initrd /live/initrd.img
}

An example of the updated grub.cfg file is attached.

PS. Support for exfat filesystem in initrd.img would be very helpful (ISO bigger than 4 GB).

Greetings
Mexit

grub.cfg.log (2,7 KB)

Hi. I had the same issue on VBox. I overcomed it using the installation tool provided in the LIVE mode of the distribution. In addition, I needed to update my VBOX (I had an old version 5.X.something). Without the updated version of VBox I got the kernel panic error while trying to start the live version

Hi there!

Parrot KDE Home 4.11

I’m not sure if this is Parrot or KDE, but if i logout using Logout button I can’t go back to the system. Password is accepted, and after the KDE/Plasma loading page the whole monitor stays just black. Unfortunately can’t see any logs, only a reboot helps to be back on the system.