Parrot 4.2 development discussions


#22

Always take the official git version and make a /pentest/ directory with all tools you use and if you want i make a script for updating them like an apt update but for git :wink:


(Lorenzo "Palinuro" Faletra) #23

no please, we would never accept such kind of approach


(Lorenzo "Palinuro" Faletra) #24

Parrot 4.2 will be released on Monday


(hydra) #25

I also recommend you to send a notification (I don’t know the procedure) to distrowatch.com on each new version of Parrot if you want more visibility.


(dmknght) #26

https://mirror.0x.sg/parrot/iso/4.2/Parrot-security-4.2_amd64.iso give me 404 error and testing folder is empty. I guess Parrot 4.2 is released. I was about creating Parrot image and testing for GUI delay (on my medium-end system) but i am too late :’(


(Ja Roslaw) #27

https://archive.parrotsec.org/parrot/iso/4.2/


(Ja Roslaw) #28

btw. It looks like cryptsetup is not supported anymore.
Encrypted persistence is not asking for password during loading system.


(Lorenzo "Palinuro" Faletra) #29

singapore mirror works for me in italy.
retry now, maybe the mirror was synchronizing when the error occurred

parrot 4.2 will be officially released on monday, now we are just waiting for mirrors to synchronize and for a restricted group of community members to notice the new images on the mirrors and start seeding the torrent :slight_smile:


(Lorenzo "Palinuro" Faletra) #30

cryptsetup is fully supported, please open a dedicated topic in the support section and describe your problem there

it would also make easier for other people with your same problem to find a possible solution


#31

cryptsetup doesnt work i create a usb with dd with the parrot 4.2 security amd64 iso then fdisk create the sdb3 partition, then i use the normal way of setting the encryted partition up like so

cryptsetup --verbose --verify-passphrase luksFormat /dev/sdb3
cryptsetup luksOpen /dev/sdb3 my_usb
mkfs.ext4 -L persistence /dev/mapper/my_usb
e2label /dev/mapper/my_usb persistence
mkdir -p /mnt/my_usb
mount /dev/mapper/my_usb /mnt/my_usb
echo “/ union” > /mnt/my_usb/persistence.conf
umount /dev/mapper/my_usb
cryptsetup luksClose /dev/mapper/my_usb
reboot

when i click encrypted persistence from the grub were the password entry bit usually is i get a
/init line 247 unable to load custom mounts

ive tried 3 times and still the same


#32

thanks for fixing the cryptsetup, i can verify this works now


#33

when we can be able to dist-upgrade for 4.2?? because still the 4.18


#34

yeah i understand you cant but we cant stay with outdated software for your pleasure lol… like metasploit you say up to date months after the framework updated, thats nightly update man


(Lorenzo "Palinuro" Faletra) #35

parrot 4.2.1 ships linux 4,18

4.18 is the kernel, not the parrot version


#36

thats why i ask for 4.18… you release the kernel version on the parrot version post??