Parrot 4.4 can't see NVMe SSD!

Briefly describe your issue below:

Hello,

When trying to install Parrot Security 4.4 or Parrot Home 4.4 from a live USB stick, the installer can’t see my primary NVMe SSD (Corsair Force MP510)

What version of Parrot are you running? Latest 4.4
What method did you use to install Parrot? Both
Configured to multiboot with other systems? no
If there are any error messages or relevant logs, post them below: No error messages, but the new NVMe isn’t displayed in the disk selection section. Both Ubuntu and Linux Mint can see drive and install without any problem. But I WANT Parrot as my main OS. Please help!

Thanks,
Aiki

1 Like

check for BIOS updates, you may need a special driver although corsair isnt opensource, I have found RGB keyboard drivers on github so check there.

1 Like

Thank you. I’ve updated the BIOS to the latest version. Nothing has changed. How come other distros like Ubuntu can see and install on it no problem?

Interestingly both Parrot and Kali fail the same way.

I’ve temporarily put an old Sata 3 SSD into the second drive bay and Parrot installed no problem. But I want the OS to sit on the fast NVMe. Am I the only one using NVMe drives here?

1 Like

the problem is not about kali or parrot, but a lack of package installed by default, Ubuntu installs many packages for ease of usability. maybe try going on live ubuntu and grep what tools are installed by default and search for something tied to NVME SSD.

2 Likes

Thank you for the suggestion! Problem is I’m still a newbie when it comes to Linux, so the task isn’t easy for me. I will work my way through some tutorials and see if that helps. No matter what, not going back to windows. Thanks.

1 Like

Search github for corsair nvme driver and see if that brings anything up

1 Like

I know that this an old thread, but figured I should reply here just in case people come back to it.
SO I have been trying to install parrot OS on my dell xps that has an nvme m.2. Oddly enough I found the fix that worked for me and hopefully future installers can try the same and reply back if it worked.

  • So in my bios I have Legacy boot on and USB boot enabled.
  • I live boot into the USB
  • parrotOS can see the NVME drive on legacy but not os UEFI boot for some reason.
    Um not sure why this is the case, anyways i installed parrot while being in legacy mode,
  • once that is done, you will need to switch the bios to UEFI mode in order to boot up,
    but once again the laptop now will boot but ParrotOS will get some error and leave you at a terminal screen

To get around this issue, I found that going back into the bios and switching the sata option to ACHI allows parrotOS to find the NVME drive during installation as well as if already installed allowed it to boot properly.

So long story short, go into BIOS and look for the SATA option, change that to ACHI.

  • my dell laptop was set to RAID by default.

It has nothing to do with a lack packages being installed but more so with installer, i believe since parrot is based on ubuntu its installer is most likely similar and ubuntu installer by default looks for hard drives on the route of /dev/sda meanwhile NVME m.2 drive on the system goes by /dev/nvme… thus the route is never found.