Parrot 4.8 Bug Report

Place for reporting bugs in Parrot 4.8
Please use the following template:

What version of Parrot are you running? (type "cat /etc/os-release" in terminal without the quotes)
    Include version (e.g. 4.5), edition(e.g. Home), 
    and architecture (currently we only support 
    amd64)

    What hardware are you running? (Machine Model/Brand, graphics card if display issue)

    What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

    Configured to multiboot with other systems? (yes / no)

    If there are any similar issues or solutions, link to them below:

    If there are any error messages or relevant logs, post them below: 

Thanks!

4 Likes

4.8; Lenovo y700 laptop; Nvidia 960m + Intel hd 530 gpu. Yes dualboot but both os are on different disks.

Winetricks can not be installed “” ip 104.27.131.193 443 " it is not accessible 404 error is showing .

1 Like

Well, that may be repository error from Wine.
I just checked their official website. They have added new repo and that repository might not have been included in the OS.
Full details here: https://forum.winehq.org/viewtopic.php?f=8&t=31621

Captura de ecrã no 2020-04-08 16-40-11
Captura de ecrã no 2020-04-08 16-49-17
Captura de ecrã no 2020-04-08 16-54-33

A bug in net installer that make it can’t be used
https://community.parrotlinux.org/t/libc6-udev-bug-in-netinstaller/12404

There are users complains about locale error shows up on terminal. it could be issue after 4.8 fresh install

This bug is solved in 4.8.1 beta netinstaller. We should keep tracking it until final release

result of os-release

PRETTY_NAME="Parrot GNU/Linux 4.8"
NAME="Parrot GNU/Linux"
ID=parrot
ID_LIKE=debian
VERSION="4.8"
VERSION_ID="4.8"
HOME_URL="https://www.parrotlinux.org/"
SUPPORT_URL="https://community.parrotlinux.org/"
BUG_REPORT_URL="https://nest.parrot.sh/"
What hardware are you running?

> A: HP pavillion 15 series, intel i5.

What method did you use to install Parrot?

> A: Debian GTK

Configured to multiboot with other systems?

> A: NO

Bug:-

While connecting to a Vpn, If, the password is wrong, a pop up shows up
like this!

And if we click cancel ‘twice’ the wifi icon disappears on the panel
like

And i have to reboot my pc to get the icon back

Is there any fix to this, for me without rebooting the computer

I’m using Parrot OS Home (MATE) on USB with encrypted persistence, and recently updated using parrot-upgrade.

I’ve noticed that the resolv.conf isn’t always being updated when Anonsurf is stopped.

When started, the resolv.conf is changed to 127.0.0.1

When stopped, I think it’s supposed to revert back to what it was originally. This sometimes works, but other times it stays at 127.0.0.1 and internet connectivity is lost.

The other alternative is that Anonsurf is working as expected and something else on the system is changing my resolv.conf to 127.0.0.1 before anonsurf backs it up to /etc/resolv.conf.bak. I don’t think this is the case though as I’d have noticed my internet connection disappear before connecting to anonsurf.

Parrot OS Home (MATE) on USB with encrypted persistence, and recently updated using parrot-upgrade

Can’t install Thunderbird:

sudo apt install thunderbird

results in the following:

The following packages have unmet dependencies:
 thunderbird : Depends: libevent-2.1-6 (>= 2.1.8-stable) but it is not installable
           Depends: libffi6 (>= 3.0.4) but it is not installable
           Recommends: lightning (= 1:68.6.0-1~deb10u1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

See https://community.parrotsec.org/t/cant-install-thunderbird/12546/9 regarding above thunderbird dependency issue

What version of Parrot are you running? (type "cat /etc/os-release" in terminal without the quotes)
    Include version (e.g. 4.5), edition(e.g. Home), 
    and architecture (currently we only support 
    amd64)
PRETTY_NAME="Parrot GNU/Linux 4.8"
NAME="Parrot GNU/Linux"
ID=parrot
ID_LIKE=debian
VERSION="4.8"
VERSION_ID="4.8"
HOME_URL="https://www.parrotlinux.org/"
SUPPORT_URL="https://community.parrotlinux.org/"
BUG_REPORT_URL="https://nest.parrot.sh/"


    What hardware are you running? (Machine Model/Brand, graphics card if display issue)
Lenovo ideapad 320-15IKB
    What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian standard
    Configured to multiboot with other systems? (yes / no)
no 

Yesterday I updated parrot and got strange bug. It crashes the plasmashell like in this video.so far I noticed long text in the “active window control” causes this crash. And there’s also this font rendering issue. Both problems appeared after update.


2020-04-25_15-34

1 Like

(Edit by RTP: moved this post to this thread as 4 other posts were made on this exact topic, cleaned it up) Left 1 thread open/pinned for discussion temporarily (1 week) at: https://community.parrotlinux.org/t/font-render-problem/12599/12

Briefly describe your issue below:
After upgrading Parrot Security 4.8 the fonts for my Applications menu, Places menu and etc. no longer exist. All I have are small boxes full of numbers.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
I’m running Parrot Security 4.8 amd64.

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)
yes

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
Here’s a screenshot that shows what the DE boots up to.App Menu

Does anyone know how I would go about fixing this?

1 Like

Hello,
I got this issue too, but I was able to fix it. I run KDE and after upgrading and a reboot, I got the same issue all over the place. Before reboot it was only one or two new started applications that displayed faulty.
Anyway, I went into KDE System settings into “Fonts” and selected different fonts to display, and at first it didn’t help at all.
What fixed it however apparently was in KDE system settings, selecting Application Style and then Gnome/GTK Application Style and there changing the font to a different one. Try this please and let us know if it works.
Thanks, with regards,
Hiro

Edit: In case you have a different DE, I suggest changing the fonts anyway until everything renders readable again. In my case, not every application was using the faulty fonts (i.e., system settings rendered correctly) and it seems like the GTK applications were the only ones affected.

4 Likes

It worked.
Thaks

1 Like