Parrot 4.9 boot loop

Parrot login screen stuck at boot loop I enter my password and it shows a blank screen then shows the login screen again the only way I can login is by pressing ctr+alt+f1 on the login screen then type in the login and password then startx please help

1.When you are into the shell (tty)
Run ls -lA , If you see the lines
-rw------- 1 root root 51 May 6 11:24 .Xauthority
-rw------- 1 root root 5406 May 6 11:24 .ICEauthority

then you need to do
chown username:username .Xauthority
chown username:username .ICEauthority

Here change ‘username’ with your username

2.Check /var/log/Xorg.0.log any errors/problems
also check /home/user/.xsession-errors

3.if you have a Nvidia Graphics Card
list it below also if you have installed the corresponding Graphics Drivers

Thanks let me try that

thanks it worked by the way do you know how i can login to root from the new login interface

if you’re on KDE then
go to System settings > User & Groups
find your user then click on it the click on the button Administrator Mode or something similar to that

for Mate i guess its the same

(as i run Parrot OS Mate Live+Persistence i dont see any such option)

That boot loop you are talking about is also triggered if you select gnome + default xsession(don’t remember clearly) Desktop Environment on lockscreen.
Just in case it’s happening to someone else also amd they selected that instead of kde or mate (According to parrot flavour installed (