Parrot 4.9 Bug Report

Place for reporting bugs in Parrot 4.9
Please use the following template:

What version of Parrot are you running? (type "cat /etc/os-release" in terminal without the quotes)
    Include version (e.g. 4.5), edition(e.g. Home), 
    and architecture (currently we only support 
    amd64)

    What hardware are you running? (Machine Model/Brand, graphics card if display issue)

    What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

    Configured to multiboot with other systems? (yes / no)

    If there are any similar issues or solutions, link to them below:

    If there are any error messages or relevant logs, post them below: 

Thanks!

4 Likes

4.9 netinstaller still has the cert bug

1 Like

A user on Twitter reported this:
Upgraded Parrot 4.8 to 4.9 (4.8 installed in VMWare through an ISO file and upgraded by terminal) and lost drag n drop vmware feature, even reinstalling VMWare Tools.User had to install open-vm-tools-desktop to resolve this and wanted to share with us in case someone encounter this issue.

Add the bug report: gksu doesn’t work with calamares which disabled root account configuration. it was fixed in the code by using gksudo (as user suggested on twitter). Watiing for Palinuro to update it.

Hi this parrot version is sooooo buggy
1- I have ralink wifi adapter
It doesn’t work ! Why ?
Because parrot 4.9 haven’t firmware-ralink
Package

2- when I tenther it through my phone
I have never seen such bug in parrot that the tenther get closed by itself on the phone
Tried to tenther windows and worked but parrot 4.9 doesn’t work
So please consider to rebuild parrot 4.9 with the required drivers to be usable probably
also i tried connecting using wpa_supplicant and only log i get is Disconnected as my phone and windows can connect to the wifi oh and i have used calamares installer to install parrot 4.9

1 Like

What is the difference between the 4.9 ISO and the 4.9.1 ISO?

Fix for the menu: use gksudo instead of gksu. Root password problem (unexpected from installer)
Fix calamares installer causes non DNS problem when it was installed without internet connection
Update for anonsurf: Fix dnstool: wrong status detection and wrong /run/resolvconf path. It also support obfs4 bridge support which is under testing

Does this also fix the "Waiting for ‘#’ modules’ in Calamares? I’ve had it happen on a few installs, had to abort and use the Debian installer instead.

I don’t know. I have never seen that before.

Version: 4.9 Security Mate
Architecture: amd64
Brand: Asus laptop
Not configured to multiboot

Hey y’all, this issue has been bugging me from the time I started to use parrot. Each time I boot into parrot its like throwing a dice, am I going to have internet or not, so my issue is when I boot sometimes it just doesn’t give me WiFi for no reason and I have to reboot the distro multiple times for it to fix itself and that’s just annoying, so I’ve so far tried running ifconfig and for some reason it doesn’t show any of my cards.

This problem is the same in the live iso, sometimes you have WiFi other times you don’t

hi again …
i have installed parrot kde 4.9.1 with calamares installer once and with gtk one on the live boot menu
now the wifi works thank you parrot team
but anonsurf doesn’t work -_-
tried from menu and from terminal and tried to catch logs with sudo tail -f /var/log/syslog | grep “tor”
only i get using tor in clear net
also tried sudo anonsurf start-bridge and the same any help?

I’m installed parrots OS 4.9.1 and after installing , I get bug wifi and Bluetooth can’t display . Just Ethernet only . Pls to fix this problem .

Hello,
Why this error is more announce to me?
I have installed 4.9.1 release.
I can not install any network tools such as SSH or VNC server! Why?

insserv: Script ntp has overlapping Default-Start and Default-Stop runlevels (2 3 4 5) and (2 3 4 5).
** This should be fixed.**
insserv: Script ssh has overlapping Default-Start and Default-Stop runlevels (2 3 4 5) and (2 3 4 5).
** This should be fixed**

1 Like

Welcome to the ParrotOS Community :hugs:

Similar to Bug #932290 but it appears no one wants to fix this.

2 Likes

2020-05-20T00:00:00Z
After searching for the font render problem today i got to THIS
i checked my system and found that i have 5 fonts which have been affected
Font Error-rt

then i tried to revert back but it seems i cannot as it will remove many packages included system & DE.
output : Here

though i don’t have any problems but i would like if there is a solution to this soon as some users are completely unable to use their OS.

:smiley: Please find a solution Soon :pray:

Thank You


@I_Have_Treasure

When pressed super (windows) key + T, it opens two default Parrot Terminal and that in distorted form with big fonts. A minor bug

I have a problem using anonsurf …Everytime I start anonsurf my Firefox cannot connect to the server.and still tor cannot connect… am using parrot os KDE security version…

2020-05-23T00:00:00Z
Font Problem finally Fixed
Original Post : Here
Now Font Error-Fixed
(*The last font is not important to me but it seems to work in Inkscape)

How Did i Fix ?
1.Visit Here and download the following packages:

libpango-1.0-0_1.42.4-7~deb10u1_amd64.deb  
libpangoxft-1.0-0_1.42.4-7~deb10u1_amd64.deb 
libpangocairo-1.0-0_1.42.4-7~deb10u1_amd64.deb 
gir1.2-pango-1.0_1.42.4-7~deb10u1_amd64.deb
libpangoft2-1.0-0_1.42.4-7~deb10u1_amd64.deb 

2.open the directory where you downloaded the packages then open a terminal in the directory and run
Command : Here
(This is a 1 Single Command)

Done! (and the fonts were back again and usable/readable)

if you want you can lock it so it doesn’t update automatically
Screenshot at 2020-05-24 02-50-11

How To Lock a Package to the Current Version (Debian only)
To lock a package to the current version follow these steps:
1.Select the package that you want to lock in the package list.
2.Choose Package ▸ Lock Version.

The Synaptic Package Manager will reload the package information. You should now see, that the menu item Package ▸ Lock Version is checked. Furthermore all actions in the menu Package are disabled now.

(*To unlock the package uncheck Package ▸ Lock Version.)

You can give this a try if you are facing similar issue.
this worked for me *maybe it should work on your system also.

Thank You


@I_Have_Treasure

in parrot 4.9 release there is a issue with switching user
i cant find any switch option to normal user to root user
by default it is showing normal user but when i want to switch to root i cant