Parrot 4.9 Bug Report

Version: 4.9 Security Mate
Architecture: amd64
Brand: Asus laptop
Not configured to multiboot

Hey y’all, this issue has been bugging me from the time I started to use parrot. Each time I boot into parrot its like throwing a dice, am I going to have internet or not, so my issue is when I boot sometimes it just doesn’t give me WiFi for no reason and I have to reboot the distro multiple times for it to fix itself and that’s just annoying, so I’ve so far tried running ifconfig and for some reason it doesn’t show any of my cards.

This problem is the same in the live iso, sometimes you have WiFi other times you don’t

hi again …
i have installed parrot kde 4.9.1 with calamares installer once and with gtk one on the live boot menu
now the wifi works thank you parrot team
but anonsurf doesn’t work -_-
tried from menu and from terminal and tried to catch logs with sudo tail -f /var/log/syslog | grep “tor”
only i get using tor in clear net
also tried sudo anonsurf start-bridge and the same any help?

I’m installed parrots OS 4.9.1 and after installing , I get bug wifi and Bluetooth can’t display . Just Ethernet only . Pls to fix this problem .

Hello,
Why this error is more announce to me?
I have installed 4.9.1 release.
I can not install any network tools such as SSH or VNC server! Why?

insserv: Script ntp has overlapping Default-Start and Default-Stop runlevels (2 3 4 5) and (2 3 4 5).
** This should be fixed.**
insserv: Script ssh has overlapping Default-Start and Default-Stop runlevels (2 3 4 5) and (2 3 4 5).
** This should be fixed**

1 Like

Welcome to the ParrotOS Community :hugs:

Similar to Bug #932290 but it appears no one wants to fix this.

2 Likes

2020-05-20T00:00:00Z
After searching for the font render problem today i got to THIS
i checked my system and found that i have 5 fonts which have been affected
Font Error-rt

then i tried to revert back but it seems i cannot as it will remove many packages included system & DE.
output : Here

though i don’t have any problems but i would like if there is a solution to this soon as some users are completely unable to use their OS.

:smiley: Please find a solution Soon :pray:

Thank You


@I_Have_Treasure

When pressed super (windows) key + T, it opens two default Parrot Terminal and that in distorted form with big fonts. A minor bug

1 Like

I have a problem using anonsurf …Everytime I start anonsurf my Firefox cannot connect to the server.and still tor cannot connect… am using parrot os KDE security version…

2020-05-23T00:00:00Z
Font Problem finally Fixed
Original Post : Here
Now Font Error-Fixed
(*The last font is not important to me but it seems to work in Inkscape)

How Did i Fix ?
1.Visit Here and download the following packages:

libpango-1.0-0_1.42.4-7~deb10u1_amd64.deb  
libpangoxft-1.0-0_1.42.4-7~deb10u1_amd64.deb 
libpangocairo-1.0-0_1.42.4-7~deb10u1_amd64.deb 
gir1.2-pango-1.0_1.42.4-7~deb10u1_amd64.deb
libpangoft2-1.0-0_1.42.4-7~deb10u1_amd64.deb 

2.open the directory where you downloaded the packages then open a terminal in the directory and run
Command : Here
(This is a 1 Single Command)

Done! (and the fonts were back again and usable/readable)

if you want you can lock it so it doesn’t update automatically
Screenshot at 2020-05-24 02-50-11

How To Lock a Package to the Current Version (Debian only)
To lock a package to the current version follow these steps:
1.Select the package that you want to lock in the package list.
2.Choose Package ▸ Lock Version.

The Synaptic Package Manager will reload the package information. You should now see, that the menu item Package ▸ Lock Version is checked. Furthermore all actions in the menu Package are disabled now.

(*To unlock the package uncheck Package ▸ Lock Version.)

You can give this a try if you are facing similar issue.
this worked for me *maybe it should work on your system also.

Thank You


@I_Have_Treasure

1 Like

in parrot 4.9 release there is a issue with switching user
i cant find any switch option to normal user to root user
by default it is showing normal user but when i want to switch to root i cant

well it has been out since long time
only you can do now is through terminal

This is bug report topic. This is NOT HOW TO SOLVE A RETARDED PROBLEM topic.

1 Like

Is there a Server Maintenance going on or parrot os servers are again under a DOS attack?
because i’m getting 521 Origin Down Error

└──╼ $sudo apt update
Err:1 https://deb.parrot.sh/parrot rolling InRelease
  521  Origin Down [IP: 2606:4700:3037::681b:83c1 443]
Err:2 https://deb.parrot.sh/parrot rolling-security InRelease
  521  Origin Down [IP: 2606:4700:3037::681b:83c1 443]
Reading package lists... Done
E: Failed to fetch https://deb.parrot.sh/parrot/dists/rolling/InRelease  521  Origin Down [IP: 2606:4700:3037::681b:83c1 443]
E: The repository 'https://deb.parrot.sh/parrot rolling InRelease' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch https://deb.parrot.sh/parrot/dists/rolling-security/InRelease  521  Origin Down [IP: 2606:4700:3037::681b:83c1 443]
E: The repository 'https://deb.parrot.sh/parrot rolling-security InRelease' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

SORRY My Fault
(Answered : Here)

It is not ddos attack. It is a bug in cdn code. and this IS NOT bug of Parrot 4.9. Stop flooding bug report topic by offtopic problem.

1 Like

when you try to log out or switch user the system crashes and shows black screen with some terminal like messages
Parrot Version [4.9]
Operating System: Parrot GNU/Linux 4.9
KDE Plasma Version: 5.17.5
KDE Frameworks Version: 5.62.0
Qt Version: 5.12.5
Kernel Version: 5.6.0-2parrot1-amd64
OS Type: 64-bit
Processors: 8 × Intel® Core™ i5-8250U CPU @ 1.60GHz
Memory: 7.7 GiB

Laptop Model is Acer Aspire E15

What version of Parrot are you running?

Parros Security 4.9.1 Oracle VM Virtualbox OVA

What hardware are you running? (Machine Model/Brand, graphics card if display issue)

Oracle VM VirtualBox (6.1.8-137981~Ubuntu~eoan) in Ubuntu 20.04 Host

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

4.9.1 OVA Import

Seems, like 4.9.1 OVA has problems with resolv/DNS settings. Right after import DNS resolution doesn’t works as expected.

My network configuration from imported OVA:

eth0: connected to Wired connection 1
        "Intel 82540EM"
        ethernet (e1000), 08:00:27:0F:75:95, hw, mtu 1500
        ip4 default
        inet4 10.0.2.15/24
        route4 0.0.0.0/0
        route4 10.0.2.0/24
        inet6 fe80::5965:b61a:dec4:9f4f/64
        route6 fe80::/64
        route6 ff00::/8

lo: unmanaged
        "lo"
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
        servers: 10.0.2.3
        domains: x
        interface: eth0

hello parrot os devs i just migrated from windows to parrot os latest version as the only system on my asus x540lj laptop i installed the system with the standard installation method without any other systems the problem is with my touchpad it doesnt work when i open my pc i got a message that says i2c designware timeout and i think this is the cause of the issue hope i found a solution because i like this distro

Welcome to the ParrotOS Community :hugs:

try this
first go to /etc/default/grub then add i8042.nomux=1 i8042.reset nomodeset (nomodeset is optional) to GRUB_CMDLINE_LINUX_DEFAULT= after quiet splash then save it and run sudo update-grub then reboot the system and check if the touchpad is working or not ,if it works keep it else you can remove this.

it should look something like this:
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash i8042.nomux=1 i8042.reset nomodeset”
*however it may vary if there are any additional commands

1 Like

i tried this before but none of this worked and thank you so much for your ansower

Hi. I have the same issue. I don’t know the solution but I suggest you to use the following command instead of reboot.
$ sudo service network-manager restart