Parrot 4.9 Bug Report

well it has been out since long time
only you can do now is through terminal

This is bug report topic. This is NOT HOW TO SOLVE A RETARDED PROBLEM topic.

1 Like

Is there a Server Maintenance going on or parrot os servers are again under a DOS attack?
because i’m getting 521 Origin Down Error

└──╼ $sudo apt update
Err:1 https://deb.parrot.sh/parrot rolling InRelease
  521  Origin Down [IP: 2606:4700:3037::681b:83c1 443]
Err:2 https://deb.parrot.sh/parrot rolling-security InRelease
  521  Origin Down [IP: 2606:4700:3037::681b:83c1 443]
Reading package lists... Done
E: Failed to fetch https://deb.parrot.sh/parrot/dists/rolling/InRelease  521  Origin Down [IP: 2606:4700:3037::681b:83c1 443]
E: The repository 'https://deb.parrot.sh/parrot rolling InRelease' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch https://deb.parrot.sh/parrot/dists/rolling-security/InRelease  521  Origin Down [IP: 2606:4700:3037::681b:83c1 443]
E: The repository 'https://deb.parrot.sh/parrot rolling-security InRelease' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

SORRY My Fault
(Answered : Here)

It is not ddos attack. It is a bug in cdn code. and this IS NOT bug of Parrot 4.9. Stop flooding bug report topic by offtopic problem.

1 Like

when you try to log out or switch user the system crashes and shows black screen with some terminal like messages
Parrot Version [4.9]
Operating System: Parrot GNU/Linux 4.9
KDE Plasma Version: 5.17.5
KDE Frameworks Version: 5.62.0
Qt Version: 5.12.5
Kernel Version: 5.6.0-2parrot1-amd64
OS Type: 64-bit
Processors: 8 × Intel® Core™ i5-8250U CPU @ 1.60GHz
Memory: 7.7 GiB

Laptop Model is Acer Aspire E15

What version of Parrot are you running?

Parros Security 4.9.1 Oracle VM Virtualbox OVA

What hardware are you running? (Machine Model/Brand, graphics card if display issue)

Oracle VM VirtualBox (6.1.8-137981~Ubuntu~eoan) in Ubuntu 20.04 Host

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

4.9.1 OVA Import

Seems, like 4.9.1 OVA has problems with resolv/DNS settings. Right after import DNS resolution doesn’t works as expected.

My network configuration from imported OVA:

eth0: connected to Wired connection 1
        "Intel 82540EM"
        ethernet (e1000), 08:00:27:0F:75:95, hw, mtu 1500
        ip4 default
        inet4 10.0.2.15/24
        route4 0.0.0.0/0
        route4 10.0.2.0/24
        inet6 fe80::5965:b61a:dec4:9f4f/64
        route6 fe80::/64
        route6 ff00::/8

lo: unmanaged
        "lo"
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
        servers: 10.0.2.3
        domains: x
        interface: eth0

hello parrot os devs i just migrated from windows to parrot os latest version as the only system on my asus x540lj laptop i installed the system with the standard installation method without any other systems the problem is with my touchpad it doesnt work when i open my pc i got a message that says i2c designware timeout and i think this is the cause of the issue hope i found a solution because i like this distro

Welcome to the ParrotOS Community :hugs:

try this
first go to /etc/default/grub then add i8042.nomux=1 i8042.reset nomodeset (nomodeset is optional) to GRUB_CMDLINE_LINUX_DEFAULT= after quiet splash then save it and run sudo update-grub then reboot the system and check if the touchpad is working or not ,if it works keep it else you can remove this.

it should look something like this:
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash i8042.nomux=1 i8042.reset nomodeset”
*however it may vary if there are any additional commands

1 Like

i tried this before but none of this worked and thank you so much for your ansower

Hi. I have the same issue. I don’t know the solution but I suggest you to use the following command instead of reboot.
$ sudo service network-manager restart

Version: 4.9 Security Mate
Architecture: amd64
Hardware: Lenovo Ideapad 320 (80XS), Radeon R7
Install Method: Debian GTK
Multiboot: Windows 10 Home 10.0.19041 (factory install)

Default install process, only exception is I did not install with a swap partition.
Installed on free disk space as cleared by windows disk manager. Used Parrot-security-4.9.1_x64.iso burned to a sd card using balenaEtcher.

No noted similar issues in current report line.

Issue: Appears to load normal until login screen. Login screen appears to have a dot grid and is off center. Once logged in, the majority of the desktop is… shifted. If rebooting or shutting down it will temporarily clear up to a normal desktop for half a second just before actual shutdown.

Images uploaded below as example.

Desktop: Desktop
Login: Login

Well this login screen is new, its not broken
its completely fine.
have you again run sudo parrot-upgrade well that may fix the issue sometime

you can go through this as well
link: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1867668/comments/16

1 Like

this was something i was thinking of yesterday,and really didn’t even consider prior.
i was curious as to how to go about updating drivers on this OS with this device?
that link at least steers me in the right direction,but doesn’t clarify for me what i should be using,and how i should go about determining that?

well these types of problems basically associates with Xorg and the display driver so

I haven’t had many issues in that area,so i count myself as lucky…
the only thing that i have noticed is what looks like a diagonal line when in the browser while scrolling pages,and also at times during streaming. it isn’t too bad,but it is noticeable.

have you tried enabling hardware acceleration?

It’s enabled.

I’ve tweaked this thing so much over the last few days that i really couldn’t tell you what actually caused it…?
as i said,it’s not terrible,and as i learn more i’m sure i’ll eventually be able to resolve it…

i’m actually still trying to understand the advice given in the other comment thread…

"After cycling back and forth between the two edits mentioned,i find that this one performs better,at least on this device.

the addition of (zswap.zpool=z3fold” ) to the command line seems to add lag / latency,and just overall slower performance.

Reply

dmknghtParrot Dev

1d

Use links2-gtk

2 Replies

1

Reply

novarion zion

23h

So you’re saying…

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash zswap.enabled=1 zswap.compressor=lz4” :-1:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet zswap.enabled=1 zswap.compressor=lz4 zswap.zpool=z3fold” :-1:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash zswap.enabled=1 zswap.compressor=lz4 links2-gtk" :+1: ??? "

I’ve seen some say they try to avoid using the gtk command line,and i really do understand what he was actually saying to do here,maybe you do?

Trying both the parrot-upgrade and the xserver uninstall did not make any changes. I ran the uninstall first is recovery mode, tested, then with a little luck the parrot-upgrade in DE mode. After reboot, still no change.

Any other ideas?

got a bug but it is not frequent
so after i put down the laptop’s screen and put up it after some time, at the login screen, i can’t type the password though i can see and click other options like those unlock, switch user, etc. Other than that, I can’t click on the password tab and type the password and login

1 Like