Parrot 4.9 Home installation issues

Briefly describe your issue below: After many failed attempts to install Parrot 4.9 home on a partition of my formerly only windows laptop, it seems to have worked now using the option in the installation manager (not the one that is accessed from the live version) that leaves the least options to change stuff manually. (Previously when installing from inside the live test version I got errors relating to it not being able to install GRUB as there was no bios boot partition, later it claimed the image I attempted to install was too large). When installing GRUB, it did not detect the other operating system (windows 8.1), but I followed the instructions in an internet tutorial and clicked “yes” when it asked if GRUB was to be installed on the master boot record. I also made sure to select the hard drive to install it on in the next step. However, upon reboot, GRUB was not present and it went directly into windows again. I have subsequently tried the following: and but to no avail (I also wasn’t entirely sure which exact partition to choose but I have tried all of them and none worked). I really don’t know what else to do, so if anyone could give me a hint I’d be grateful!

What version of Parrot are you running? 4.9 home, trying to dual boot with win8.1

What method did you use to install Parrot? installed from a live usb

Configured to multiboot with other systems? (yes / no) yes

What are your BIOS settings like (what changes did you make/ensure before doing the install)?

Have you given the “Install” from booting to usb/dvd a try instead of live install?

I had to disable the secure boot option and I changed the boot order for it to boot from the usb. Fast boot is disabled, “launch CSM” is enabled. And yes, my last attempt (which looked successful but apparently didn’t work) was selecting “Install” in the first screen appearing (i.e. not going into live mode first).
According to the messages I got during installation, GRUB was installed, however it still just boots into Windows and the options in the BIOS haven’t changed (there is nothing new to choose from in terms of boot order, but I also don’t know if there should be).

Having also tried the GTK installer I run ino the exact same problem. Installation of Parrot and GRUB complete, but it only boots into Windows. Same if I attempt to install GRUB anywhere else from the MBR.
I really don’t know what else might be going wrong…

Solved! The problem was that I was trying to install it in BIOS mode when my system is in UEFI mode. It previously could not be booted in UEFI mode and I’m not exactly sure what I changed, but it might have just been the boot order of the usb and uefi usb.
Anyway, it’s running now! :partying_face:
Whoa. Looking forward to installing Parrot on my other machine as well!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.