Parrot 5.0 Call for Beta Testers - 3

We’re almost there! Thanks again for helping us test the second beta image of Parrot 5.0. Now the major problems are resolved, and now you can proceed with testing our new release. If you test the iso, leave a report in the comments of this thread.
DOWNLOAD LINK HERE: Parrot 5.0 Beta 3

Here’s the template:

*-- Please Write below your test experience  --* 

+ Hardware information: (post output of ` inxi -MSNGAmPrdC`, if you don't have it, install it with `sudo apt install inxi`)

+ **Logs/Terminal output** *(use pastebin or similar services)***:**  

+ **Screenshots:**  

Overall, I’m very excited to be running Parrot-architect-5.0-beta3_i386.iso on an old Compaq Mini 110 netbook!

Processor: Intel Atom N270 @ 1.6 GHz
Memory: 1 GB
(LOL :astonished:)

Just an observation, not a gripe, but similar to versions of Kali Linux i386 after 2019.1a, the Parrot Beta 3 ISO does not provide the (proprietary?) Wi-Fi drivers for my old netbooks. I had to use Ethernet to install Parrot (mirrors) and later installed the needed packages to do the trick…


The Calamares “Login without a password” still doesn’t work. I understand this is an unsafe option, but I often LUKS encrypt the drive and would prefer to put in only one password at boot-up, then wait for the desktop to load. I know I can edit the /etc/lightdm/lightdm.conf to allow auto-login.

Missing from Parrot i386:

Noted (so far) missing packages from Parrot i386 but available in Kali i386:
OpenVAS (Greenbone)

Elsewise, installing Parrot-security-5.0-beta3_amd64.iso in VirtualBox (Windows 10 host) gives a different Grub error at the end of install then in Beta 1 & 2.

1 Like

inxi -MSNGAmPrdC → Parrot_5_Beta_3 -


Still have problems with the grub.

According to Mesmer, i386 works in VirtualBox BUT without selecting any extra package. If I check Parrot base packages and extra pentest tools, the installer return a error due to grub-pc.

Actually, I installed the i386 Beta 3 version on an ancient netbook and it works. I already installed all the available security tools and more.

Edit: Are you saying that during install, if you select more than just the base packages and Mate desktop and try to install extra pentest tools, then you have grub error at the end of install? (I’m installing the i386 version in VirtualBox and just got to that screen to select packages. I go with only the base packages and Mate as they are on the (smaller) ISO.)

The x64 Beta 3 I tried installing on VirtualBox has the grub-pc error. Once the grub error is fixed (Beta 4?) we can report more issues. :rofl:

Parrot 5 Beta 3 on Compaq Mini 110c (102?) netbook screenshot…

@breizhim, I try both versions, home & security, same error.

We should add fcitx to preinstalled tool again?
In this beta 3, the live medium doesn’t have grub-pc which caused no installation candidate. The solution could be either put it to live medium or get from internet.

were you able to install it? I will try to do what you tell me, to see what I can do.

I don’t know who you are asking Ajra, but the i386 Parrot 5 Architect Beta 3 (a.k.a. new 32-bit) version installs on x86 hardware and on VirtualBox when you select Debian 32-bit. Don’t select additional software during install, just the base install and Mate which are pre-selected. After rebooting into Parrot you can install pentesting packages.

@Masmer I was asked to @dmknght, but your answer helped! Thanks.

beta 6 is building. Palinuro finally fixed the error (in theory) grub-pc no installation candidate. By checking mounted iso, grub-pc is in media source

1 Like

Beta 6 is having an other installation error and we are fixing it. Some minor bugs in parrot-menu are being fixed as well

I’m downloading Beta 6 now. Should I skip it?

Edit: Nevermind… (yes)

you should skip it. the installation is still having error (ofc different error). It’s better to try next release. I’ve pushed a fix and update for linux-exploit-suggester. There are some more packages are going to be updated.

1 Like

I had the same error.

Guys please don’t use beta 6 for now.
when we will release it, we’ll open the related thread.

1 Like

@tissy questions would you publish in the parrot os blog when the update is available?

Looking forward to a new release.

Please make sure that sound is working out of the box on newer hardware.
Here is inxi from one of my machines without any sound at all:

System: Host: lxuser-xps179710 Kernel: 5.14.0-9parrot1-amd64 x86_64 bits: 64 Desktop: MATE 1.24.1
Distro: Parrot OS 5.0 (LTS)
Machine: Type: Laptop System: Dell product: XPS 17 9710 v: N/A serial: 2RFBLG3
Mobo: Dell model: 012MMP v: A01 serial: /2RFBLG3/CNWSC001BC0025/ UEFI: Dell v: 1.2.0 date: 06/15/2021
Memory: RAM: total: 62.55 GiB used: 5.57 GiB (8.9%)
Array-1: capacity: 64 GiB slots: 2 EC: None
Device-1: DIMM 1 size: 32 GiB speed: 3200 MT/s
Device-2: DIMM 2 size: 32 GiB speed: 3200 MT/s
CPU: Info: 8-Core model: 11th Gen Intel Core i9-11980HK bits: 64 type: MT MCP cache: L2: 24 MiB
Speed: 1738 MHz min/max: 800/4900 MHz Core speeds (MHz): 1: 1738 2: 1585 3: 1896 4: 3821 5: 3092 6: 1565 7: 1800
8: 2325 9: 2731 10: 1789 11: 1522 12: 2073 13: 3750 14: 3426 15: 1711 16: 2713
Graphics: Device-1: Intel driver: i915 v: kernel
Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] driver: nvidia v: 470.57.02
Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
Display: server: X.Org 1.20.11 driver: loaded: modesetting,nvidia unloaded: fbdev,nouveau,vesa resolution:
1: 1680x1050~60Hz 2: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 20.3.5
Audio: Device-1: Intel driver: snd_hda_intel
Device-2: NVIDIA driver: snd_hda_intel
Sound Server-1: ALSA v: k5.14.0-9parrot1-amd64 running: yes
Sound Server-2: PulseAudio v: 14.2 running: yes
Sound Server-3: PipeWire v: 0.3.19 running: yes
Network: Device-1: Intel driver: iwlwifi
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
Drives: Local Storage: total: 2.65 TiB used: 572.73 GiB (21.1%)
ID-1: /dev/mmcblk0 model: SC128 size: 119.08 GiB
ID-2: /dev/nvme0n1 vendor: Micron model: 3400 NVMe 2048GB size: 1.86 TiB
ID-3: /dev/sda type: USB vendor: GALAX model: GX024010A100-A1 size: 223.57 GiB
ID-4: /dev/sdb type: USB vendor: SanDisk model: USB 3.2Gen1 size: 460.27 GiB
Message: No optical or floppy data found.
Partition: ID-1: / size: 1.8 TiB used: 238.06 GiB (12.9%) fs: btrfs dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 299.4 MiB used: 292 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1
ID-3: /home size: 1.8 TiB used: 238.06 GiB (12.9%) fs: btrfs dev: /dev/nvme0n1p2
ID-4: swap-1 size: 68.8 GiB used: 768 KiB (0.0%) fs: swap dev: /dev/nvme0n1p3

1 Like

Hello, is there no longer a Parrot 5.0 beta to test? Download link is broken.