Parrot becomes unbootable out of nowhere

Briefly describe your issue below:

At random times, Parrot becomes unbootable. I’ve got no idea how, but it seemed to happen mostly when VT-x was enabled in EUFI and when booting Windows. It has happened today again and it seems to be incredibly random, out of nowhere. I know this description of my problem is very vague but that is because I’m not really sure what is happening. This is a one-timer for me.

When this problem occurs, GRUB is just gone. It doesn’t show up in the boot order in my UEFI settings, but the motherboard and other software can still detect the disk.

Windows 10 and Parrot are installed on separate disks. The SMART readings indicate that the disk parrot is installed on is healthy and functioning.

What version of Parrot are you running?

Parrot security edition, installed from the latest ISO and updated to the latest packages as of 03/04/2019, running on 64-bit (amd64).

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

The debian standard installer. I did custom partitioning as follows:

  • /dev/sdb1: is my /boot/efi partition, 142M large
  • /dev/sdb2: is my /boot partition, 650M large

The rest of the disk is an encrypted LVM, which includes

  • A 30GB SWAP partition
  • the 267GB that remains is my root partition.

Configured to multiboot with other systems? (yes / no)

Yes, I have three disks to accomplish my multiboot.

/dev/sda is my 3TB storage drive that i primarily use while using windows (to install games etc.).

/dev/sdb is the drive where Parrot is installed.

/dev/sdc is my Windows 10 C:\ drive.

It must be noted that GRUB can successfully detect and boot both OS’s, before GRUB gets removed magically.

Secure boot is disabled, too.

If there are any similar issues or solutions, link to them below:

This is probably the same problem that I’m having.

This too, but to me it didn’t occur after an update and reinstalling grub only temporarily fixes the issue.

If there are any error messages or relevant logs, post them below:

None, sadly.

UPDATE: I just chrooted into my install and decided to run some diagnostics. I decided to run:

 efibootmgr --verbose | grep parrot

And I got the following output:

EFI variables are not supported on this system.

Also, the file /boot/efi/EFI/parrot/grubx64.efi still exists.

After reinstalling GRUB from the chroot environment, the command efibootmgr --verbose | grep parrot does have an output

Maybe this will help?

I just re-installed GRUB and the system is bootable for now. Is there anything i need to keep in mind next time this bug happens?

Yeah this might be a difficult one to diagnose.

If it happens again, try to remember what you did on parrot before hand (Maybe check your bash_history). Or what windows did (Check updates times).

It wouldn’t surprise me if windows was responsible for breaking it. Although they will have separate MBR’s, so it shouldn’t be overwriting grub.

Yeah, I’ve never seen this before (even with parrot) and i’d say I’ve been using Linux for some time now. Will reply to this thread if I discover anything.

Okay so the problem happened again.

PC starts up as normal and GRUB shows up. I select the windows boot entry, and the windows bootloader freezes. The “disk usage light” is not flickering, the keyboard/mouse not lighting up, just the windows logo with no loading animation underneath it, which there is in normal situations.

Because nothing happened, i decided to restart. I press the power button one time and everything immediately shuts off. When i restart the PC, the PC successfully boots into windows, but GRUB is gone.

The last thing I did on parrot was doing an ‘apt upgrade’ and downloading/reading some (secure) PDF files, the last thing I did on windows was watch youtube videos and open some CAD programs, so i’m left with more questions than answers.

Any idea on how I go from here?

I am wondering if the issues doesnt come from having 2 efi partition ? Check in bios if the windows efi doesnt make his way on the top bootable option. Try installing grub in the efi of windows, it might help.

Windows does not go above grub in the boot order, the parrot boot entry just disappears from the nvram entirely.

I’m not sure how I can install grub on the same partition as my windows bootloader, without breaking the windows boot. Just “grub-install /dev/-drive-that-windows-is-installed-on” should do the trick?

Parrot wont replace windows as in mbr system it will create a file at its side. The file will redirected to grub that should include windows boot option.
Yeah the command you mentionned should do the trick.

I think I solved the problem without reformatting or installing GRUB on another drive. I’ll say “i think” because I’m not sure if this is the solution, but so far the bug hasn’t happened after i applied this fix.

So what I did, was just enter the following command in Windows:

bcdedit /set {bootmgr} path \EFI\parrot\grubx64.efi

What I think it does is that it tells Windows to expect a different bootloader than the one it is used to, and as a result doesn’t want to fix it.

If the bug still doesn’t happen in 2 weeks, i’ll mark this thread solved.

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.