Parrot drops to initramfs shell before desktop, cant install

Attempting to install Parrot Security MATE 4.10. I successfully flash it onto a USB using Balena Etcher. Connect USB to target computer. Power on and open boot menu. Boot from USB to open Parrot GNU. Select Live. Brings up Parrot logo with aura showing progress (polygon background screen), all seems fine. After a minute or two, but before the desktop is ever shown (where I would directly install Parrot from), it drops to initramfs shell (BusyBox v1.30.1). I have tried literally every suggestion I can find on this forum and through google, but I have had no luck. When I use the exit command I get a kernal panic - not syncing warning and an attempted kill. It then freezes here. How should I go about getting Parrot to install successfully? Will provide any information as requested. Thanks for the help.

Hi Erik,

What is your PC’s relevant hardware? (i.e. RAM, Processor, Make\Model, laptop or PC, dual boot, x86 or x64).

Have you tried booting via Live USB any different distro successfully? (i.e. Ubuntu, Kali, etc.)

It could possibly also be an issue with the USB drive you are using or the USB 2.0 or 3.x port you have it plugged into.

RAM: CORSAIR Vengeance LPX 32GB (2 x 16GB) 288-Pin DDR4 SDRAM DDR4 3600 (PC4 28800) Intel XMP 2.0 Desktop Memory Model CMK32GX4M2D3600C18
Mobo: GIGABYTE Z490I AORUS ULTRA LGA 1200 Intel Z490 Mini-ITX
CPU: Intel Core i7-10700K Comet Lake 8-Core 3.8 GHz LGA 1200 125W

I am attempting to dual boot with Windows 10 from a partitioned SSD. I have tried installing Kali Linux as well. When I try this install I get the same error as when I try to directly install Parrot from the GNU. After selecting languages/keyboard layouts, it then tries to detect hardware to find installation media. This is where it fails. I get a “No device for installation media was detected. You may need to load additional drivers from removable media, such as a driver floppy or a USB stick. If you have these available now, insert the media, and continue. Otherwise, you will be given the option to manually select some modules.” I have been unable to find how to fix this problem/what drivers are being referred to. It also doesn’t seem to try to find a USB drive, only a cdrom, which I don’t have.

I have used the same flash drive that I was able to install Windows 10 with. I have tried it with two different USB 2.0 ports (including the one that Windows 10 was installed through).

Oh, you are booting “from” a partitioned SSD connected as a USB?

Boot from it to a live desktop (not the GTK installer) and before installing, find out what drive and partition the installer is on using fdisk or GParted.

Launch a terminal next and type in

sudo mkdir /cdrom

Then, depending on what drive\partition (xx) the live boot\installer is on

sudo mount -t vfat /dev/sdxx /cdrom

With luck, the installer should be able to access the installation media.

I am booting from a USB drive with the intention to install Parrot onto my partitioned SSD.

So I am attempting to get to the Live desktop. When I select Live, it brings up the Parrot logo, but eventually drops to that initramfs shell before the desktop environment is ever shown. Because of this, I am unable to launch a terminal.

1 Like

Are you able to get to a new terminal at that point by pressing Ctrl-Alt-F1?

Can you upload a screenshot of your partitions in Windows from diskmgmt.msc? Thanks!

What was used to make the installation media? This warning suggests the usb was properly imaged. BTW the usb is the cdrom. Back story: .iso files are the same type of filesystem traditionally on those ancient circular shaped artifacts called cd’s. When you properly create the installation media the usb becomes an exact copy of what would have in previous times been distributed on a disk.

Try the “gfx safemode/safemode”, maybe “nomodeset”. The options should been there if not they’re under “advanced settings”.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.