Parrot home fail to install

I trying to install parrot home KDE/mate third day without success I downloaded various iso from direct download/torrent KDE/Mate.
Trying belana etcher as well Rufus with DD option. After USB is flashed with a parrot is so small and contains only boot and EFI folder inside USB, and size (original is 14 GB) after parrot is flashed is just 716 KB… 20 KB free of 716KB… I tried as well another USB and the same situation. Waiting for some solution. Thank you.

any error during installation?

There is no error during installation. Are there any other tools like Rufus etcher which I give a try with a parrot?

could you provide a screenshot of the partition table of the usb you flashed the iso.

Sure, here is last one. I just now flashed with belana etcher.Screenshot_2

your issue seems similar to this : Here

could you provide some details about your pendrive.

It’s Toshiba 16 GB but I also used OSOCOO 8 GB and same. Ubuntu it flash and run normal.

The status is health in diskmgmt.msc. I fixed it with diskpart 100 times and flashed again and again to both usb and same same same issue with probably all combination like different parrot iso images/usb flash tools/ and both KDE and mate desktop environment.

could you please verify the ISO’s
From : Here

1 Like

I’ve checked and they are good…:frowning:
I just flashed normal debian with rufus and it’s boot normal on my 8GB USB.
Do you maybe know any other USB tools with dd option?

are you trying to install Parrot OS on the usb stick or the hard drive?

I try to install it on the USB stick.

just make 2 partitions for that pendrive one for root mounted as /
another for home
size per the need
and be sure to select the correct usb stick during installation
mounted usb are usually at /dev/sdb or /dev/sdc
check and install

1 Like

Sorry, I don’t understand a bit. Make 2 partitions and then flash with Rufus or etcher?

no in during the process you can do it

1 Like

during, how? Not after the process?

Still cannot fix it. Even I installed parrot on VM and downloaded there etcher and then flashed. USb looks the same after flashing from Linux. As you can see in the picture above there is 2,048 GB partition where I could see files from Linux and there are all iso files but as you can see it’s “not formated” I have no idea why. When I click properties on this partition I see this download (1)
Now question is can I can somehow fix that partition after is flashed? Then I am sure it will boot, but I don’t know what to do now how I can fix that partition.

Try this Tool : Isolyzer
or i guess your pendrives Do Not support the ISO 9660 format filesystem.

  1. Use diskpart to clean your usb. Video how to: https://www.youtube.com/watch?v=D7EgjYeCybE&feature=emb_title

  2. Format your usb to FAT32 video how to: https://www.youtube.com/watch?v=q_UtpgwIoi4

  3. Download .iso from Parrot website. Than use belana etcher to make it bootable.

  4. Turn off secure boot from your computer BOIS and fast boot(If have in BOIS). If your using windows 8, 8.1, 10 follow this: https:///www.youtube.com/watch?v=ry3BgjFBAW0&feature=emb_title

  5. Now you can boot into your usb.

Note: After your usb has been flashed with parrot. Dont worry about the size of usb or what folders inside usb. Just boot from usb and install Parrot. After done installing you can clean your usb using GParted on parrot or diskpart. If have another windows computer(re-follow step #1 for this).

Once you clean(format) your usb the missing space in usb will come back.

This screenshot doesn’t show a problem. You have a partition of the filesystem, isofs, which you can read in the corner. There are not bytes writable because isofs are read-only. This is why live media is read-only. I bet if you try to boot from it things would work just fine.