Parrot is so slow!

Hi. I recently installed Parrot OS on my laptop. I initially installed ISO image on both VMware and Virtualbox, with 1gb ram. I discovered that parrot was super slow. So slow, that only opening firefox crashes the machine. I later increased the ram to 2gb, and only then it started to work fine. I still face lags, and sometimes crashes. Even though my laptop is pretty weak, I found that Kali runs a lot faster in this laptop, given the same resources. Why is this happening? Isn’t parrot a lot lighter and faster, with minimum 256mb ram? Does anybody know a possible solution?

Ps. I am running on Intel core i3, with 4gb ram and integrated graphics.

Which DE of Parrot are you using?
Kali is using the XFCE which is very lightweight and more lightweight compare to Mate or KDE.
And yes Kali now is very lightweight and it surprised me.
We are having the OS optimization plan to improve our runtime quality. If you have any idea like packaging removing, services disabling,… please feel free to send email to us team@parrotsec.org

1 Like

If you were to run Parrot directly on your laptop without using a type-2 hypervisor, it would run OK. But with VirtualBox or VMware on top of another OS with your specs? Forget it. It’s technology, not magic.

You might want to look into BlackArch Linux using the i3 or OpenBox WM. Maybe Back Box Linux.

Parrot Security 4.10 Mate memory used before and after Firefox is launched.

Parrot XFCE 4.11 Beta 2 memory used before and after Firefox is launched.

Kali 2020.4 memory used before and after Firefox is launched.

1 Like

There is 1 more reason that Parrot has many configurations in skel so it could use much ram. We’ll optimize it as well.

2 Likes

I am running a Dell Inspiron 1525 Core2 Duo and 8GB Ram and so far I have no problems with this OS. This computer was made in 2009 and has two cores. You should add another stick of ram to you laptop, 4GB is not enough to run on these days.

Please check if you provide some amount of Swap memory. Because, In my case, I faced a terrible amount of lagging due to swap memory. If you also agree with me then disable swap and enjoy!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.