Parrot menu doesn't use default terminal

Briefly describe your issue below:

I got a new terminal and I already changed it under prefered applications. Yet, entries from parrot don’t respect my settings and they continue to start mate-terminal. After removing mate-terminal, xterm get’s used instead! I already tried modifying the “menuexec” script, but I couldn’t find anything to modify.

What version of Parrot are you running?

Parrot 4.7 MATE security edition on amd64.

What method did you use to install Parrot?

GTK Installer.

Configured to multiboot with other systems?


If there are any similar issues or solutions, link to them below:

Does anyone have any idea? This bug is insanely annoying and i can’t seem to locate it whatsoever

Okay i’ve done some more troubleshooting. I ran a menu entry without menuexec and it still opened up xterm. So the problem is the MATE launchers themselves. Anyone else got more input on this case?

EDIT: With xterm removed, no menu opens. My best guess is that this is something hardcoded?

Man I even tried removing both mate-terminal and xterm and create symbolic links for both, it didn’t help.

Does no one really have an idea how this can be done? I’m going insane!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.