Parrot Os 90 seconds delay... PLS HELP

Hello Guys,

Yesterday i installed parrot os and everything was good but then i realise that the shutdown option has a delay of 90 seconds.

Can you help me please, Thanks

I’am using Parrot Sec version 4.11 64 bit

I used GTK to install Parrot Os

I use Windows 10 and Parrot Os Dual Boot

Here is a picture of my laptop specs:

pretty strange

usually it’s just caused by some programs refusing to stop when receiving SIGHUP/SIGTERM

1 Like

I think same but after using the pc about an 3-4 hour it shutdowns perfectly

How about shutdown -h now ?

Nope doesnt work.

In etc/systemd/system.conf There is a shutdown delay of 90sec as default. But it should be commented out.

I take it that the 90 seconds wait is on the grey shutdown screen? If you hit ‘esc’ whilst on the grey screen it will give you an output that might tell you what it is stuck on.

Sorry, but what is a grey screen?

when you power off your system the screen goes grey as it finishes up background tasks. (might be black for you depending on monitor settings) But seeing as you dont know what i mean it doubt that is where the problem is.

Try logging off then shutting down and see if it still does it.

here you go a image of the problem

Looks like some LVM2 service isnt stopping properly. But other than that im not sure tbh.

its just refusing to shutdown but its not a big problem.