Parrot-OS black screen on Macbook pro

I have installed parrot on macbook but its not booting black screen shows up and hangs there.

Any help please?

You could read the logs and try to find the Problem. Another option would be to reinstall.

1 Like

There’s no log, and i have tired sevral times even i checked Kali linux, but the same issue.

Have you been able to successfully install parrot or anything else on this MacBook? Does it have a bios setting preventing the install?

No there was no error during the installation, nothing prevents the installation process.

You should still check the bios as the install may complete but won’t boot due to boot security within the bios. I’ve seen it on HP laptops recently.

May also be a graphics issue? But that wouldn’t make much sense since you can do the install fine.

That’s about it for my knowledge of MacBooks. Sorry. Good luck. If you figure it out be sure to let us know.

yes i think it maybe graphic issue but i have tried several ways. i have deactivated the graphic in grub but it still not working.

I found this article not sure if it’ll help or not but might be worth the read.

https://forums.developer.apple.com/thread/117190

Hello! Did you manage to solve the problem? In my installation, a similar problem and I suspect that it is due to discrete graphics. At startup it freezes. I tried to use nomodeset, it does not help.

no not yet, i also tried that option but it didn’t work for me

I hate to see you still having this issue. One thing I would like to point out is try to include as much information as possible in your initial question to get the best response (different models of macbook carry different pieces of hardware; One fix does not fix all macbooks). Not only that but the support forum has rules for questions including hardware.

Not including important info can result in your post becoming “unlisted” or invisible to others until you include proper Support post requirements However, I am not going to do that this time so others can see this post (hopefully ppl are able to learn from it). Support guidelines are at: https://community.parrotlinux.org/t/support-guidelines/1226

What kind of graphics card do you have? What model macbook? Can you further explain this black screen? Is there a blinking cursor? error message?

Does anything happen on your macbook using fn+ctrl+alt+F1 ?

Did you have any issues with live booting Parrot? Did you see anything at boot (grub, etc)? When did the screen turn black (right away or after grub)?

Please be descriptive in your entire process for better results on the forum. I am leaving this thread up so others are sure to follow the support post guidelines (and so they can read it).

But of course we still want to help if you can give us more information :slight_smile:

Hello!
I will voice my problem in this thread.
My Macbook Pro (15-inch, early 2011). Graphics AMD Radeon HD 6750M 1024 MB and Intel HD Graphics 3000 512 MB. When starting without the nomodeset parameter, after “loading initial ramdisk …” appears on the black screen with the cursor and everything freezes. “Fn + Ctrl + Alt + F1” does not call the terminal. If you start the OS with the nomodeset parameter, then after “loading initial ramdisk …” you go to the black screen and the inscription “[drm: radeon_init [radeon]] * ERROR * No UMS support in radeon module!” Appears, then a picture with parrot and there is a transition to a black screen with a blinking cursor. “Fn + Ctrl + Alt + F1” calls the terminal. The output of the command “uname -a” in the terminal “Linux parrot 5.2.0-2parrot1-amd64”

Hello!
I had some free time during which I found out that the problem is in radeon graphics. Radeon driver which only loads properly on MacOs in BIOS emulation mode. The way out of this situation, in my opinion, is to disable Radeon and force EFI to use the integrated Intel graphics card, check the following topic on a third-party resource:
Force 2011 macbook to use integrated

2 Likes

Hello!
I launched ParrotOS on my MacbookPro 15 (2011).
As I wrote earlier, the OS can only be launched with integrated Intel graphics:

2020-01-24_21-12

In order to do this, you must:

  1. Start the OS with the parameter nomodeset = 0
  2. Wait for the blinking cursor and start the terminal: Fn + Ctrl + Alt + F1.
  3. Open the file “/boot/grub/grub.cfg”.
  4. Find quiet splash and after quiet splash add “i915.lvds_channel_mode = 2 i915.modeset = 1 i915.lvds_use_ssc = 0”
  5. Find set gfxmode and set the parameters:
    “set gfxmode = keep
    outb 0x728 1
    outb 0x710 2
    outb 0x740 2
    outb 0x750 0
    load_video”
  6. Save
  7. Update grub: “update-grub”
  8. Reboot the OS and enjoy parrot)))
1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.