Parrot os ect/resolv.conf is empty after installation

Okay i was using parrot os on a virtual box for a while then i loved it i decided to make it one of my operating system so i dual boothed it with windows windows being the default os
Its faster than virtual box when u actually install it on you pc
Suprisingly i found that the was a problem with the network
*i can browse the internet even though i have data on my router
*apt/apt-get say its experiencing temporary problem (that seem to be like permenant problem)
*i only have the “lo” interface no “ethe0” or something like that
And my /etc/resolv.conf is empty
And there is no /etc/resolvconf or /etc/resolv.headers or things like that i have trued to find many solutions but all of them need a conputer that is able run apt-get upgrade which requires an ip
I tried live mode but this copy of parrot foesnt see to have wifi drivers that can scan for wifi

Basically iys useless for hacking if it dpesnt have an ip address or a working internet connection
If you have any sugestion it would be highly appriciated
Laptop:lenovo
Os: parrot os 4.9 rolling😑
I like this os but i am thinking of giving up

Run command sudo dnstool static opennic

Latest release version is 4.10

It’s up to you.

3 Likes

That’s where your actual problem is then. If you have no interfaces that can reach the internet of course…or it doesn’t matter whether there are any name server entries there because you can’t any anyways.

Still no change but i appriciate your help