Parrot OS freezes (dual boot)

Hello guys, just found this forum, wanted to discuss a problem with my Parrot OS, if I open 10-15 tabs in my browser or do some other heavy duty task that runs smoothly on Windows 10 (its a dual boot PC) it runs out of RAM, the bar on the top of desktop shows that 100% PC is being used and Parrot OS just gets freezed. Why is it so and how can I avoid my OS from getting freezed. I have i5 processor with 8GB ram, it is a dual boot PC. Free space on my disk is 50GB. I have several softwares installed in it like Megasync, telegram app, signal app, I am using it like regular distro besides my pen testing tasks. Is it ok?

If Windows is running smoother, that sure doesn’t sound right. :sweat_smile:

Find out what processes are using up the ram and check logs (don’t paste entire log, only the small segments related to this memory/cpu usage and time). Not much we can say until we see that.


Thank you for your response. Actually whenever I open multiple windows, my OS starts to misbehave, either it be 15 tabs on Mozilla, or Mozilla with Teamviewer, Terminal, Telegram, VSCode open. I have checked “htop” when this happens but htop does not show any suspicious entry, there are only those programs listed that I have opened, so that seems okay too but it shows that my 8GB RAM has been used completely, which is pretty strange.

P.s I like your username!

1 Like

Next time you have the problem, you could run something like

ps -aux | awk '{print $2, $4, $11}'| sort -k2rn | head --lines 10

Paste the output of that one liner, in your next reply. Should list 10 most hogging processes.

I’ve been experiencing freezing on my three Parrot Security 4.10 installs: a Laptop install, USB install, and a VMware install on a PC. The CPU randomly goes to 100% and locks up everything for sometimes dozens of minutes. Sometimes the clock continues, sometimes it freezes up as well. The System Monitor shows the CPU is busy, but I’ll have to do RightToPrivacy’s suggestion once my system stops it’s current 9 minute and counting hang.


1 Like

I doubt I can run this command if my PC gets completely frozen :expressionless:

Exactly, you experiencing the same on three different platforms, is it something wrong with Parrot? Anyways do share your experience with the command.

I installed Stacer and saw that the freeradius server service was running all the time with high memory usage, so disabled it as I don’t need it. I’ll be working on my laptop this morning and see if this solves the problem or not.

I should note that I used this command to see freeradius-server was on top, then used Stacer to disable the service.

1 Like

A quick help only with the symptom is to Add to Panel the Force Quit button. If it is a common problem it will get solved eventually. It might be from the Max Memory or disk space allocated by the kernel… or stack…

The OS just gets unresponsive and this command cant be run untill unless I restart the computer which obviously will bring the OS in normal state and then there is no point of running this command.

I have checked through stacer the processes running on my PC, they’re not suspicious its all just Chromium and Firefox most of the time, also if OS starts to give indication of getting freezed I checked the processes and it was all pretty obvious and nothing abnormal, it’s just strange that why the RAM gets eaten up so quickly. Any solution to that?

Tried, but that button also jams when the OS freezes

Did it solve the issue?

So today I had an online quiz and the Parrot OS once again got freezed during the exam. I nearly missed a huge trouble, I dont know how can this issue be fixed in Parrot :confused:

can you show the screenshot of htop once
maybe you ram usage is full along with swap or have you not created swap? (Not needed in case of ssds)

1 Like

I have HDD but no swap on my OS, The screenshot is as follows:

probably your ram usage was full and then during further usage, it got freeze?
or your harddisk is old
other than that freezing should not have occured.
for further research, we can look at /var/log/message

Someone said me that swap is a must on HDDs and that my issue is due to no swap is it true?

The log messages was pretty lengthy I have shared a portion of that file here:

This issue has become a headache for me.
I have tried making swapfile on my OS, but failed, someone on Parrot Telegram group said that I’ll need to fresh install parrot OS and this time with swap. It doesnt sounds really good

no making swap file is also ok
where did you get error while creating swap file?

It was when I enabled swapon on swap file, anyways, I have successfully made a 11GB swap partition separately.