Parrot OS grub bootloader problem

Greetings.

This is my first reply and i signed-up just to get help with the GNU HRUB 2.02 Beta Version, cause it is driving me crazy; and help others with all I know.

Partition size 200 Gbs
Installation mode: Via USB through installer option

1 Like

still no solution?

I really need help

found the fix.

follow up the steps i mentiioned and you should be good to go.

Good luck guys :slight_smile:.

1 Like

First things first. In order to solve this problem you need to start in your bios settings. Look for the menu that allows you to change the boot order, this makes a big difference. You’ll need to rearrange the boot order so your USB drive loads first, the second disk that needs to be loaded is the target disk or partition you’re installing Parrot on. Save those settings and reboot the computer. If it all goes will then you should have booted straight into your Live USB. I highly highly suggest using the old school installer rather than booting straight into the live OS. There’s no need to load into the OS and have pretty graphics just to install an OS. I had struggled with these issues back in Parrot 3.5-3.8 kept testing different ways to get the install to take. Now I get grub every time I turn on my computer with menu options for Win10 or my other Linux box’s. Disk booting order is very very critical with dual/triple/quad booting.

1 Like

I tried to install Parrot 4.4 from a live DVD onto one of my freshly formatted drives and it always failed to install the bootloader. I tried both Grub and LiLo. After several hours of frustration I gave up and installed Debian 9 which I think uses the same install program and it was successful. After some looking I ran across the info suggesting using etcher to make a bootable usb Parrot install and that was the ticket. The install was uneventful and successful. Anyway I’m test driving Parrot 4.4 and enjoying it. Thanks for a great distro!

2 Likes

I also I’m having problems loading parrot. IA was booting from a live USB in persistence until around a space and decided to install on a hard drive that was 6 hours ago. I’m still letting it run in hopes that it is installing but I don’t think it is anymore .I think it’s stuck.

About to shut it down in hopes of starting over.

Also parrot thinks my hard drive belongs to somebody else.

Did you change the bios settings?
Can you provide the linl of what you used to make the installer?

Hi do you know how to use the parrot security recovery mode please help me I run full update after restarting it boots up and blinking so I turn off and go to the second option where you can see the parrot security recovery option advance

this is ok i’m try

https://ddser.cn/category/kali-linux/
good luck
grub leader :slight_smile:
/boot/vmlinuz-4.19.0-parrot1-13t-amd64 root=2 ro quiet splash noautomount quiet nouveau.modeset=0