Parrot OS not booting up

Briefly describe your issue below:
The os does not boot up i made it my main os and it does not work i made another topic but none seems to care about this problem soninmade another one… I can see parrot os logo and its loading but then it gives a black screen with nothing and sometimes just " _ "
I can open the shell by Ctrl+Alt+F1…
I tried live boot it has same problem i tried encrypted lvm boot ithas same problem recovery mode still same problem i tried encrypted lvm boot still same
Now i tried installing and booting on parrot os Home version and same problem this is so messed up…

My specs are something
128GB
And ram 4GB

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
4.6

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard

Configured to multiboot with other systems? (yes / no)
No
If there are any similar issues or solutions, link to them below:
Nothing
If there are any error messages or relevant logs, post them below:
Nothing

What bios settings did you change?

check the settings of your bios.

If you get tty shell

  1. Add new user
  2. Login into it from shell
  3. Try service lightdm start
    Not work
    startx
    Still not

sudo apt install xfce
xfce

Still not, live boot & change kernel to old (if you deleted)
Try to boot in another kernal