Parrot OS raspberry pi 3 B+


When I try to install Parrot Os on my new Raspberry Pi 3 B +, it simply does not start.
I suspect the image has not yet been updated for the new pi 3 b +? Or maybe I’m doing something wrong, but I really do not think so.
I read on the internet that developers have to update their operating system for the raspberry pi 3 b + because it needs more and other drivers (other chipset, etc.)
Will there be an update soon?

Same problem here. Latest image runs on my Raspi 2B just fine, but will not boot on the Raspi 3B+. Red LED flashes 4 slow and 4 quick and under-power lightning bolt is displayed at. I tried running first on Raspi 2B to allow it to setup and expand partition(s) and then tried to run again on Raspi 3B+, but still no go.

Making some progress. You have to add the file “bcm2710-rpi-3-b-plus.dtb” to the boot partition. That should get you past the 4 quick/4 slow red LED failed boot and under-power lightning bolt and to the GUI login with just one major boot error - it fails to load kernel modules. I also grabbed a cmdline.txt file from a working Raspi 3B+ because the console settings were slightly different (not sure if that’s important, but it booted). Just make sure that your cmdline.txt file includes the quiet filesystem expansion command from the original.

After booting, everything seems okay, but the keyboard and mouse don’t work. I was able to SSH and check lsusb. The USB keyboard and mouse both show up, so at least that part is working. They’re just not registering any activity. I started an update/dist-upgrade to see if that fixes it.

1 Like

Update/Dist-Upgrade managed to take forever and wipe out the kernel.img and kernel7.img files. Replaced the entire boot partition contents from existing Raspi 3B+ and rebooted. It booted to the desktop, but still no mouse or keyboard.

Ran sudo systemctl status systemd-modules-load.service and got this:
● systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vendor preset: enabled)
Active: failed (Result: exit-code) since Mon 2018-03-05 22:16:38 UTC; 1 months 11 days ago
Docs: man:systemd-modules-load.service(8)
Process: 118 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 118 (code=exited, status=1/FAILURE)

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

So, I’m out of ideas.

[Update]: Actually, I installed tightvncserver through SSH and was at least able to function remotely. Mouse and keyboard functioned just fine through VNC.


Thanks Scott, You’ve saved me from a bit of headbanging on my desk!

1 Like

Glad I could be of any help at all. I’ve been in I.T. my entire adult life (just stepped over the big 5-oh), but this Linux stuff makes my head implode. I know in Linux everything is a file and I know that in this case, it’s looking for files that aren’t there. Ordinarily, if this were a dependency issue I’d just do an apt-cache search and then apt install whatever’s missing. But kernel modules? Don’t you have to compile those or make or configure or stand on your head while chewing gum or something?

Anyway, I’ve learned to enjoy the endless challenges of Linux as a learning experience. (I take A LOT of notes!) I’ll figure it out in time. It’s so much fun breaking stuff with my little $35 Raspberry Pi when I can just re-image the SD card and start all over.

Good luck with 4.0! Hope to see something new soon.

Happy to hear you still have your head. Carry on. :@)

Hey. New here but I have a quick workaround coming from Kali-Pi. If you have a regular Pi 3, Zero, whatever laying around this may work (it did for me) Boot from one of the other Pi’s. Once you log in to the desktop launch a terminal. Fortunately the ParrotOS devs were kind enough to leave raspi-config and rpi-update as part of the image unlike Kali. In the terminal type sudo rpi-update . That will pull in the latest firmware from the Raspbian repos and allow the 3 B+ to boot “and” USB will work. Once you have finished the rpi-update swap the SD back into your B+ and it should boot fine.

The only alternative I can think of (if it will even work) is to try Re4son’s custom kali kernel . It contains a bunch of patches and drivers to get things like USB wifi cards and TFT screens working and may work here as well (have not tested personally so your MMV)


Thanks psy0nic. I will give that a try. Much appreciated. :smiley:
[UPDATE]: Well, poke me in the eye! That worked a treat. FYI: running sudo apt-get dist-upgrade for some reason deletes the kernel and renders the SD useless. 'Sup wit dat?! :rage:

Yup. A well documented issue that is to do with how debian updates it’s rolling distro as far as I am aware. If you search the forum for it there is a number of post about it. It’s been looked at to see if anything can be done to stop that happening.



Well, GRR! I’ll look into that. Thanks T!

Unfortunately i don’t have any other Pi then the 3b+ so i had to work it out on my own :thinking: so far i have made it to the login screen and then it freezes :triumph: also i am not able to use my bluetooth keyboard or mouse, i also tried a wired mouse with no luck. Im only new to all this so that isn’t helping much :exploding_head:

Hey Guys! I run Parrot Security os in my Raspberry Pi 3 model b+. I boots up But Keyboard & Mouse not working!!!. Please help me to fix this.

@Sanskarpandey_2013 have you tried connecting to it via ssh ? I thought my keyboard and mouse were stuffed to however i have worked out that it is all working perfectly in the background mine gets stuck on the login screen but i have full access via ssh. I believe the problem is something to do with the GUI on mine as i changed it to boot to the console via raspi-config and keyboard works perfectly

Okay, I had been missing in action, I’m finally back and ready to start “Parroting” away.

I finally have all my devices ready to get to work, namely:

-Rpi 2
-Rpi 3
-Rpi 3B+
-Rpi Zero

and all the big boys, referring to all the ALFA USB WiFi Adapters and the PAU06.

I was going to install Parrot on the Rpi 3B+, when I stumbled with this thread. So my question is the following:

Is Parrot OS not functioning with Rpi 3B+? Or it does? I am asking to not bother wasting time and going directly with what works, that being Rpi 2, Rpi 3 or even Zero W, but please let me know. I’m about to go to bed, to be fresh like a lettuce tomorrow, but I would appreciate the head start if possible.


P.S.- I’m not a computer scientist, yet. I honestly wasted my time getting another degree. However, I’m going to change this world through code sooner or later, wait and watch.

It should work on the Rpi 2 and 3, i believe thats what it was built for and tested with. You may well be able to get it working on a 3B+ following psy0nics post above. Either way the arm builds are experimental so you may have to do a bit of tinkering.

I haven’t had much luck with mine honestly, Kali works just fine on it though

Hey guys, just made an account because of this.
are there any news on an update or a fix to get this system running on a RPi3 B+?
thanks in advance.

its runs on the pi 2 and pi3 b+ but have the same problem the mouse and keys don’t work…
I put the usb later in the pi2 when the home screen shows up. but in the pi3 b+ dont work it

Unfortunately the ARM image is currently being rebuilt and it is not adviseable to use any of the old images per ARM Dev Jeff. it is estimated that it should be ready in about a month or so. I apologize for the wait, check back in about 30 days for an update!