Parrot OS Starts without password

Briefly describe your issue below:
Hello everyone, it seems that the only time I am asked to put my password in to load into the desktop is when I have shut my laptop off. Whenever I close my laptop, and reopen, it loads straight into the desktop, no pass required. This also happens whenever I forget to put my charger in,and it dies, when it comes back to life, it doesn’t ask for a password, just loads straight to the desktop. There have been a couple times that even after shutting it off, when it comes back, no pass is needed. The only consistent way I have been able to get it to ask for one is by pressing windows key + L But I need it so if I close my laptop lid, it locks. Windows does this without issue. Any help would be nice. And yes, I did change the settings in the power management.


What version of Parrot are you running? (Parrot os security, version 4.1, x64 bit)

What method did you use to install Parrot? (Debian Standard)

Configured to multiboot with other systems? (No, parrot os is the only os on my laptop)

???@palinuro

I dont have a laptop to test this on so i cant be sure it works but if you have a look in /ect/systemd/logind.conf there are some different events and actions commented out, if you un-comment ‘HandleLidSwitch’ and set it to ‘lock’.
HandleLidSwitch=lock
Note that you might have to do it the externalpower and docked ones too.

1 Like

Sorry for super late response, I was away so I didn’t have my laptop. I tried editing it, and no dice. Still doesn’t lock when I close the lid and re open

maybe is only a silly thing try this >>> system —preferences—look and feel—screen saver and check this options


let me know if password popup after the hibernation
p.s. if doesent work try to create new user on administration and try with this type of options

1 Like

Finally! I tested it out for a day, and it finally works! Thank you guys so much! I can now close my lid and reopen it to it needing the password.

1 Like