Parrot os stuck after login page

I have successfully installed parrot os as main os. It was all good and then when i start my laptop it ask for my password as usually and then there is just a blank screen and moise curser.
I tried to solve this by restarting my laptop but it is not working.
Please help me as soon as you can.

Currently i am using debian standard security edition 64bit edition.
I am not so sure about version but i am sure that it is latest.
I am using it with dual boot with ubuntu. And it was working good.

1 Like

This case is Dr.Strange

Have you just fresh installed?
Open TTy shell & login as your user and type

 startx | | startxfce4

happend to me 2x now too in the last week. i bet u see a login and u are clicking it but its not saying its bad good nothing … its more then likely your grub… and if it nots its your id lost it self and the packages are broke… i had it pretty bad all of a sudden i got apci=disabled for some reason on my x64 amd security version… i thought it was ust me but no its doing it alot… lately to ppl … im sure they will fix it

I tried but it did nothing. Please help me. I ahve my project in it and my submission datr is near.

You mean , There is data inside of Parrot?
Wait did you upgraded or fresh installed?
Live boot and copy your data

Whatever , if you have projects re-install or projects file is inside of parrot , live boot and copy your files and then re install

Before you do anything drastic here are some things you can try:

  1. Try right clicking with the mouse, this can bring up a menu allowing you to open a terminal
    in a terminal “mate-tweak”, in mate-tweak go to window and adjust HDPI value and or window manager. Also/or go to panel and choose any different option to get a reset stripped down panel.
  2. If you can’t click try “alt+t” or “ctrl+shift+t”
  3. If you can’t right click to open terminal or use macros, login into non-graphical screen with “ctrl+alt+F(1-6)” eg “ctrl+alt+F1”, “ctrl+alt+F2”, preform non-graphical operations or login as root.
2 Likes

I am actually having the same issue on my laptop.And i am also thinking we all made partition errors.
It was working beautifully minus the GRUB ERROR.nouveau_.modeset=0_ every damn time…
I dont know much i am brand new learning.
I have literally been through hell and back in the last month on 6 operating system installs and parrot just worked … so now i have no 2nd monitor and am looking for driver support for vga2usb.
Kali locks solid will not boot. worked for 2 days then dead so I move to this machine.
I wipe partitions, i reformat, I resize, i set swap i set ext4 I install again, same issue.
SO… that being said I will follow this thread and pray for an answer because ive looked for days now and found nothing.

I will try that and let you know !

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.