Parrot OS won't boot in any mode

Briefly describe your issue below:
Hi, I need some help…
After flashing the latest .iso file to a USB Flash drive, I tried getting into the OS.
I get to some sort of blue-themed loading screen, after which I’ll only have a black screen with a blinking underscore.
This happens whether I have it installed on my hard drive or live booting from the USB. I can open the shell using Alt+F2, but I don’t have access to the terminal.
Curiously, the same USB won’t work on a Mac either, so maybe there’s an error in the version I’m using?
I used Rufus to flash the .iso in dd mode, with the NTFS file system.
I’m able to boot Ubuntu, ElementaryOS and Mint, but Kali Linux and Debian would also get stuck with the same result.
I also tried using nomodeset and nouveau.modeset=0 but none of those worked.
Using sudo apt-get update and sudo apt-get upgrade doesn’t fix anything either.
The .iso file works fine in a Virtual Box (also the KDE version).

I hope anyone has any idea as to why this is. Everything I could find on the internet didn’t help…

System Specifications:
Gigabyte Z390UD
Intel i7-9700KF
Nvidia RTX 2080Ti
32GB DDR4 RAM
2TB HDD
1TB NVMe M.2 SSD with Windows 10 Home installed

What version of Parrot are you running?
4.9.1 Security KDE x86_amd64
also tried 4.9.1 Home KDE x86_amd64

What method did you use to install Parrot?
Debian Standard

Configured to multiboot with other systems?
Yes (Windows 10)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

I assume your problem is related to usb flashing.

Try rufus if you are using windows.
Change your usb file format as NTFS.
And write it in DD mode.
It will help if your computer bios is supporting UEFI.

If you are using something else, try to create your live USB with https://www.balena.io/etcher/

Let us know whether it worked or not.

1 Like

Hi @Caesar, thanks for your answer! :slight_smile:
I had done all of that before but I did it again, just to be sure.
Sadly, it still doesn’t work…
Do you have any other ideas? I’m getting really desperate now :sweat_smile:

1 Like

Have you tried changing MBR to GPT while booting?

And also is your current os booting in uefi or legacy?

1 Like

I’m booting in UEFI Mode with secure boot disabled. I’m pretty sure I tried GPT for flashing in rufus - but to be honest, I’m not quite sure how to change it during boot…

While booting press f2 or by which your computer goes into bios, it is f11 in my case. Then go to security tab and disable or enable it.

Then follow steps as follows:

  1. Flash your iso into your usb with options which are GPT, and your usb format as NTFS.
  2. Choose DD mode writing option on rufus.
  3. Plug your usb in computer and go to BIOS again, enable secure boot (mine is open)

If you follow these steps it has to work, i had the same problem once and solved it in this way.

1 Like

Okay, so regarding the security tab option, what exactly should I disable?
The flashed USB shows a little “UEFI” Label inside my BIOS, so I assume it launches in that mode.
Enabling secure boot and launching the USB gives me an “unsigned signature error” and puts me back into the BIOS. And with secure boot disabled, I only get the black screen again…

This is how mine is.
You should enable secure boot if you are booting in UEFI mode.

If this doesn’t work,
Then flash your usb with default options which are fat32 drive and MBR booting option. However, if your current os is booting in UEFI mode, it won’t help since your drivers are turned into UEFI compatible state, it requires a complete format, which you wouldn’t like to do I suppose.

If all these don’t work, i suggest you use vmware or virtualbox as a last resort. Or wait somebody else’s help.

1 Like

I’ve tried the default version before, and since that doesn’t work… guess I’ll wait a bit longer.
Thank you for your help anyways :slight_smile:

Hi, try this, security boot off then look under CPU for “SVM Mode”. and look if it is on.

1 Like

Will do as soon as I’m home, thank you! :slight_smile:

forgott, when its on turn it off ^^, and vice versa

1 Like

Okay, tried that, sadly it didn’t work :frowning:

1 Like

Since Kali, Debian and Parrot all give similar results, I think your search for a kernel cheat code is the correct approach. Look for the ‘failsafe’ menu options or try other cheat codes for hardware compatibility issues.

1 Like

Hey there, thank you for your answer! :slight_smile:
Do you mean codes like nomodeset or acpi=off?
I’ll try to find a few more :smiley:

Also, do you think the fact that I’m able to boot Kali version 2018.1 but nothing more recent is of importance?

When parrot boots - you should see an initial grub2 menu with many menu options? Do you not see this?
If not then it is not even booting to grub2! If you do see the menu, then you will see there are some menu entries (from an earlier ISO, I had):
“Failsafe (nomodeset)”
“Failsafe (disable nvdia/amd gpu)”
“Failsafe (strong errors prevention)”
If you look at the \boot\grub\grub.cfg file you will see various cheat codes are used.

1 Like

I do get into the select screen, it just fails half way through the boot sequence after selecting an option. I’ve tried every menu option, but nothing has worked yet…

1 Like

Are you MBR-booting or UEFI-booting?

1 Like

Pretty sure it’s UEFI. The USB has a “UEFI” Label next to it…

I just tried the same KDE Security 4.9.1 under VBOX 5 and 4.9.1 version does not seem to boot from a USB drive using UEFI - any option - but does boot OK using MBR\CSM under VBox. However, on real systems, it does seem to UEFI-boot OK (Asus Z87 Haswell and Lenovo IdeaPad 300). It does seem to suggest there might h/w compatibility problem in latest Debian builds maybe as I don’t get this issue with earlier Parrot ISOs. Might be worth seeing what has changed in recent versions. Maybe go back to a previous version and see where the change occurred?

1 Like