Parrot security 4.6 with UEFI instead of LEGACY?


I already became mentally retarded until I found out, how I could get parrot sec 4.6 with the 4.19 Kernel to boot into system after fresh installation of parrot on a SSD completely for itself.

It used to get stuck while booting up the system, didn’t even came to the log in screen.

There always came this failure message about WLAN0 link not ready and stuff…

So now I found out, if I Install parrot afteer changing UEFI Only to Legacy and preferred Legacy before UEFI in my BIOS = this freaking “wlan0 link not set … DHCP failure” and so on is history. Parrot boots up into system smooth as silk.

Now my problem:
There must be a way to get parrot from the created DOS partition system to being able to install parrot and run parrot witrh UEFI, GPT partition.

It can’t be so hard, to fix this wlan0 link not set failure with the freezing system boot up, can it???

What version of Parrot are you running?
parrot 4.6 security amd64 kernel 4.19

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Really all kinds! Been trying to get this running for more than a week by now.

Configured to multiboot with other systems? (yes / no)
yepp, Got 1 nvme and one 2tb ssd in my thinkpad e495 laptop.
Tried installing Windows 10 first, than parrot. Same way parrot first installed. Also tried this with nvme and ssd for different system. all possibilities tried here.

If there are any similar issues or solutions, link to them below:
Well, parrot is running if I install it with legacy boot mode on in bios. But this way parrot does not install itself in UEFI mode and creates different partitios = No GPT partitions!

It is running fine as long as I don’t give a f*** about UEFI u know :wink:

If I install parrot with UEFI, the install process takes damn’ long while installing in legacy it is like 20 times faster

If there are any error messages or relevant logs, post them below:
It gets stuck during boot up after installing parrot OS! Always at ADDRCONF (NETDEV.UP): wlan0: link is not ready

I can manage it to not show my wifi card during boot up but then it tells me my eth lan connection is getting ready, then it even tells me LAN link is up but that’s it. Boot up stops here no matter what!

Basically I just want to stay with parrot 4.6 instead of 4.7 or 4.8 because the more updates, kernels and features are integrated in the new parrot versions, THE LESS works.

In parrot 4.6 my wifi cards all (and i have 6 different cards) work immediately without stressing about wrong interface names, monitor problems and so on. Why should I use parrot 4.7 if all my wifi cards are causing problems and just won’t work right if parrot 4.6 does the job. New OS versions should be created in order to make things easier and add some features but for parrot for now it is anything but improving things.

Not a Parrot issue actually. Create your own CA cert and add it to the keyring.
search google and research EFI. It can be done, but as the Kali folks say, you have to try harder. :slight_smile:

1 Like

can you give some details please? Do I create and add the cert in windows? I mean, after installing parrot with UEFI I don’t have a achance to get into parrot after install.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.