Parrot Upgrade broke msfconsole

Not sure what is going on but after the full upgrade I was trying to run msfconsole and got the following:

[*] Bundler failed to load and returned this error:

   'cannot load such file -- bundler/setup'

[*] You may need to uninstall or upgrade bundler

I did uninstall bundler and re installed it but I am still experiencing the same issue… :

└──╼ $sudo gem uninstall bundler
Successfully uninstalled bundler-2.0.1
└──╼ $sudo gem install bundler
Fetching: bundler-2.0.1.gem (100%)
Successfully installed bundler-2.0.1
Parsing documentation for bundler-2.0.1
Installing ri documentation for bundler-2.0.1
Done installing documentation for bundler after 3 seconds
1 gem installed
└──╼ $sudo msfconsole
[*] Bundler failed to load and returned this error:

   'cannot load such file -- bundler/setup'

[*] You may need to uninstall or upgrade bundler
What version of Parrot are you running?Linux blah 4.19.0-parrot1-20t-amd64 #1 SMP Parrot 4.19.20-2parrot1.20t (2019-03-09) x86_64 GNU/Linux
What method did you use to install Parrot? Debian GTK
Configured to multiboot with other systems? no

Again all that I did was an apt update and apt full-upgrade … then I started getting that issue.

I hate to say this, but I’m glad someone else is having the same issue and it’s not just my setup.

I have the same version of metasploit-framework installed on my Manjaro box, however it appears to work fine. The latest parrot-upgrade has broken both msfconsole along with connecting to hidden password protected WiFi networks using nm-applet. :confused: Hopefully these can be resolved so they don’t make it into the 4.6 ISO. :slight_smile:

I hope someone shares the solution :S sorry about that man I feel what you feel :frowning:

I mean, no ISO release will be perfect, but I’d like to get as many kinks ironed out as I can. :slight_smile:

I had the same thing happen to me and this is how I fixed it.

Try this from your terminal:

  1. echo $GEM_PATH

  2. If it is blank check where your system will look for ruby gems with this command:

gem env

  1. Add the gem paths listed in the gem env command to your .bashrc as the GEM_PATH environment variable.

For example I added the following line to my .bashrc:

export GEM_PATH=/var/lib/gems/2.5.0:/home/$(whoami)/.gem/ruby/2.5.0:/usr/lib/x86_64-linux-gnu/rubygems-integration/2.5.0:/usr/share/rubygems-integration/2.5.0:/usr/share/rubygems-integration/all:$GEM_PATH

Open a new terminal window and metasploit should start.


I’ll try this when I get back to my flat, I’m not near the affected system at the moment, but do you care to tell me why this would fix the issue?

Sure… Metasploit depends on a ruby gem called bundler. Your computer will search all directories in your $GEM_PATH environment variable for bundler. Apparently, this is the resulting–albeit–misleading error message when a ruby program can’t find bundler.

Is this GEM_PATH export normally in the Parrot .bashrc ? I guess I never went looking and I don’t have my liveUSB with me atm.

You know I’m not entirely sure. The .bashrc file is for user specific settings so I’m essentially saving myself from setting the $GEM_PATH variable every time I open a terminal.

I just reached out to @palinuro to collaborate on a more permanent fix.

I appreciate that. I was giving a presentation earlier this morning and had to resort to the 4.5-1 liveUSB due to msfconsole issues. Hopefully I still get a good % on my assignment. Eh, my fault for not checking beforehand. :confused:

thanks so much it has worked and am going to do a youtube tutorial for sharing this with others


Awesome! it is working. It would be nice if it gets fix by the next upgrades so we don’t have to add more stuff to the .bashrc Thank you for sharing the knowledge! I really appreciate it.

1 Like

I still currently have this issue after using that command mentioned above.

Only way i get msfstart and console to work is by using the command mentioned above and in the same console windows using msfstart and msfconsole. Cant open it in any other console window. Once I close that window, I have to do it all again

You need to add the command into ~/.bashrc. It will then run automatically when you start a terminal.

1 Like

I must of been adding it into the wrong file. Thank you that worked

1 Like

we fixed it upstream, and the next metasploit update will bring the fix