Parrot-upgrade broke vagrant

Briefly describe your issue below:
Last night before I went to bed I ran sudo parrot-upgrade and saw that it was downgrading something and didnt think anything of it. This morning I went to launch my metasploitable 3 VM using vagrant up and was greeted with this error. Why would it downgrade from running and upgrade command.

Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

conflicting dependencies timers (= 4.1.1) and timers (~> 4.0.1)
Activated timers-4.0.1
which does not match conflicting dependency (= 4.1.1)

Conflicting dependency chains:
rubydns (= 1.0.3), 1.0.3 activated, depends on
timers (~> 4.0.1), 4.0.1 activated

timers (= 4.1.1)

Gems matching timers (= 4.1.1):

I have tried everything to my knowledge to reinstall rubydns but could not find a solution. Given the error I would assume its my rubydns?

What version of Parrot are you running? (include version, edition, and architecture)

Linux parrot 4.19.0-parrot1-20t-amd64 #1 SMP Parrot 4.19.20-2parrot1.20t (2019-03-09) x86_64 GNU/Linux

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Debian Standard

Configured to multiboot with other systems? (yes / no)


If there are any similar issues or solutions, link to them below:

I tried finding a way to reinstall or install the latest version of rubydns but failed to find a solution

If there are any error messages or relevant logs, post them below:


This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.