Parrot-upgrade not working

– Please Write here your help request –
I’ve been having this issue for quite a while now. So basically I have been using Parrot Security Edition in dual boot and had stopped working there for a few months. Came back to it recently and noticed parrot-upgrade was not working throwing a 404 Not Found at every package so I though maybe it was just a problem because I hadn’t updated for too long and decided to do a fresh installation again. After the fresh install the problem kept happening. I switched to another mirror /etc/apt/sources.list.d/parrot.list and after some fiddling with different mirrors I got it to be able to download some more packages, but I’m still getting errors.
Now, this might be off-topic but I also need to install VMware Workstation for a uni project and it’s also failing and I’m thinking it might have to do with my system not having the required dependencies since I have a bunch of packages to upgrade (?).

  • ParrotOS iso in use:
    I’m using the latest Parrot Security Edition Iso

  • Application used for flashing the iso:
    Balena Etcher

  • Logs/Terminal output (use pastebin or similar services):
    Here’s the terminal output for parrot-upgrade:
    parrot-upgrade log - Pastebin.com

  • Screenshots:
    My parrot.list looks like this atm:

Hi

This has been covered on this community for months with dozens of posts. For now, change your parrot.list mirror to

http://parrot.mirror.garr.it/mirrors/parrot

Even the latest VMware Workstation has issues with the latest Linux kernels. You will need to install a patch. Click on this link.

1 Like

Seems like it worked and your VMware solution worked aswell. Thanks alot, take care!

1 Like