Parrot USB drive install drops to shell

Briefly describe your issue below:

I installed Parrot OS (MATE environment) to a USB drive and I’m trying to boot into the operating system. Whenever I boot to the drive, it loads GRUB and then attempts to load into Parrot OS. It will get as far as the Parrot OS loading screen with the Parrot logo but then just drops into the BusyBox/initramfs shell each time.

I tried following the same steps found in both this and this related issue.

For the first link, I followed all of the steps successfully. The first time I tried loading after following the steps, I had the same problem. I tried rebooting and I managed to get into the OS. Every time after that, however, I run into the original problem.

For the second link, I was unable to follow the steps since the command that a user suggests to run cannot be found when I try to run it.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

Security version 4.6 MATE environment

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Debian GTK

Configured to multiboot with other systems? (yes / no)

Yes. I’m running Pop!_OS on my main hard drive and attempting to run Parrot OS on a USB drive.

If there are any similar issues or solutions, link to them below:


If there are any error messages or relevant logs, post them below:

If I type ‘exit’ at the (initramfs) prompt, I get the following output:

Gave up waiting for root file system device. Common problems:
- Boot args (cat /proc/cmdline)
  - Check rootdelay= (did the system wait long enough?)
- Missing modules (cat /proc/modules; ls /dev)
ALERT!! /dev/sdc3 does not exist. Dropping to a shell!

A lot of users are facing same issue. Messed up a lot of users. Its a bug. As far as i know the devs are working on it.

Good Luck.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.