Parrot with XFCE won't set time on startup

I installed Parrot 5.0 LTS with XFCE 4.16 on my desktop and the one thing that has been unable to hold is the system setting the time on startup. Whenever I shutdown the system and start it up again later, the time has not passed at all since the last shutdown. I cannot find anything in the settings manager that would be able to help me here, so how should I set the system to automatically set the time each time I log in?

  • ParrotOS iso in use:

  • Application used for flashing the iso:

  • Logs/Terminal output (use pastebin or similar services):

  • Screenshots:

Change your CMOS battery.

Or if u have dualboot windows then turn off auto sync there and then set timings here

It’s not the CMOS battery, other installations of other Distros and even my old Windows 10 installation still works fine there. And No, I’m not dual booting anything here

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.