Parrot won't automatically boot after install

Briefly describe your issue below:
I’ve installed multiple times using the text and graphic installations, from a USB and from a CDROM.

I’m installing on an HP ZBook with a CD drive. USB will only work to initiate the installation, during the installation the installer attempts to copy resources from the CDROM and without a CD there was no work around. I tried the "mount -t vfat… " work around that I found on this site but couldn’t get it working. But I had a CD-RW so I wrote the iso and the CDROM works for installation.

I’ve gone through the installation 4 times using both the graphic and text installer. Everything appears to be installing fine, I get no errors during installation. I can see that GRUB installs with a progress bar, but after the installation is complete Parrot OS won’t boot. I get an error after the HP splash screen that no bootable media can be found. I can still get into the OS by pressing ESC during the splash screen and then choosing “parrot” from the bootable media list but I need to do this manually every time I restart the machine. There is an option in the BIOS to setup a custom boot option but there’s no description for what I should be putting in the input box. I used blkid and can see that sda2 says “boot” so I tried entering /dev/sda2/ into the custom boot option but it doesn’t work. I’ve rearranged all of the boot options in the BIOS several times but have not been able to get an automatic boot yet. The only way to boot into the OS is to go to the bios settings and manually choose “parrot” from the list of available options.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Parrot 4.6 Sec
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard, Debian GTK from USB made with Rufus 3.6 and CDROM
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

1 Like

Etcher achieved the exact same result as Rufus.

1 Like

I found a solution and it appears that the issue is something to do with HP’s BIOS or detecting the location of the GRUB EFI file.

When the computer starts, pressing ESC doesn’t go immediately into the BIOS settings, instead pressing ESC leads to a “startup menu”. This menu has several options including System Information, System Diagnostics, Initiate Intel CIRA… Boot Device Options and BIOS Setup.

In the BIOS Setup, the user can choose which options will appear in the Boot Device Options menu, including setting a Custom Boot Option.

First I entered the Boot Device Options. This menu has the default options of OS Boot Manager, Notebook IPV4, Notebook IPV6, Boot from EFI File and “parrot” or “ubuntu” depending on which OS is installed. Side note, when I installed Ubuntu the computer had no issue booting automatically. In this menu when I select parrot the computer will boot, but instead on this occasion I chose Boot From EFI File. The next page lists only one option which is a long string “Acpi(PNP0A03,0)/Pci(1f|2)/Sata(Port 0)/HD(Part1,SigB5…” (the rest of the string looks like a serial number possibly for the SSD?) When I click on this option the next page shows \ and then two options
Selecting EFI leads to another page which shows \EFI with the options

Selecting parrot leads to another page which shows \EFI\parrot with the options


At this point I went back into the BIOS and input the following string into the Custom Boot Option:
Then I moved the Custom Boot Option to the top of the Boot list and now the computer will automatically load GRUB on startup and then continue to the OS.


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.