Parrot (XFCE) 4.11 Beta Testing

I had been testing the first Beta of Parrot 4.11 XFCE for awhile and started testing Beta 2 today: Parrot-xfce-4.11-beta2_amd64.iso.

First thing I noticed with Beta 2 is that going into Install => Install with GTK GUI got me to a point where the installer could not find the install media. Mind you, this was using VMware Workstation 14.

Install02

2 Likes

Thank you for report to us. That is strange. Last time i saw this problem was on USB stick which was made by rufus.
Does live installer work for you? I personally recommend the Calamares installer.

1 Like

No problem! I was going to post each “bug” in a separate post. Now that I can reply, here’s #2:

I was able to boot into the live installer, but once again was a victim of the light-locker while installing. I could not put in the password to get back to the installation progress.

So I rebooted into the live installer, shut off the XFCE Screensaver lock, shut off lock screen in Power, and used Synaptic to “uninstall” light-locker from the live installer and proceeded to install Parrot XFCE 4.11 Beta 2 successfully.

I rebooted and the OS booted to the desktop successfully without any issues.

1 Like

#3:

Even though I uninstalled light-locker, shut off lock screen in screensaver and in power, it will still lock the screen.

I can log back into Parrot however. It’s just an annoyance.

1 Like

@dmknght I’m using the ISO to boot

I experienced the same thing when imaging Kali using Rufus, and have to Ctrl-Alt-F# to mount the USB as /cdrom. Recently I accidentally discovered that imaging Kali using dd mode instead of iso mode in Rufus prevents that issue.

1 Like

It is xfce4-screensaver. I decided using it as official screensaver of xfce. OFc the problem is having both light-locker and xfce4-screensaver leads to this

This is a little strange. I remember i edited the list of startup applications, disabled light-locker. I have to wait the beta 3 release with full update of skel and check it again.
I also need to see how to “block” light-locker during iso building.

Well yeah i got it. That is weird bug on Parrot + iso in VM because i have never seen it before.

1 Like

BTW: I was using Beta 2 a lot today and it did not lock me out. I think I was mistaken and may have accidentally booted off the ISO thinking I had booted off the virtual drive, so bug #3 probably does not exist.

(PS: I am upset that Greenbone has once again updated their packages in 4.10 and screwed up my working OpenVAS.)

Well it must be light-locker ran before somehow i think

Maybe run the setup script multiple times fix problem

The Redis server is no longer starting.

   OK: scanner (db_address setting) is configured properly using the redis-server socket: /var/run/redis-openvas/redis-server.sock
    ERROR: redis-server is not running or not listening on socket: /var/run/redis-openvas/redis-server.sock
    FIX: You should start the redis-server with 'systemctl start redis-server@openvas.service' or configure it to listen on socket: /var/run/redis-openvas/redis-server.sock

I’ve already

sudo pluma /etc/redis/redis.conf
And uncommented the following lines:
unixsocket /var/run/redis/redis.sock
unixsocketperm 700

And tried restarting the service and also Parrot with no luck. I’ll work on it later. Thanks.

Weird. standalone redis started just fine on my vm. And unfortunately i removed the old VM that installed gvm. Can you try check any logs from journalctl?

The log just said that that redis could not start. LOL

I took a nap and followed some directions online. I used Synaptic to reinstall Redis and the various OpenVAS/Greenbone packages and this time gvm-check-setup (and gvm-setup) worked, again. :grinning:

executing “gvm-check-setup”

[sudo] password for a-man:
gvm-check-setup 20.8.0
Test completeness and readiness of GVM-20.8.0
Step 1: Checking OpenVAS (Scanner)…
OK: OpenVAS Scanner is present in version 20.8.0.
OK: Server CA Certificate is present as /var/lib/gvm/CA/servercert.pem.
Checking permissions of /var/lib/openvas/gnupg/*
OK: _gvm owns all files in /var/lib/openvas/gnupg
OK: redis-server is present.
OK: scanner (db_address setting) is configured properly using the redis-server socket: /var/run/redis-openvas/redis-server.sock
OK: redis-server is running and listening on socket: /var/run/redis-openvas/redis-server.sock.
OK: redis-server configuration is OK and redis-server is running.
OK: _gvm owns all files in /var/lib/openvas/plugins
OK: NVT collection in /var/lib/openvas/plugins contains 64519 NVTs.
Checking that the obsolete redis database has been removed
OK: No old Redis DB
OK: ospd-OpenVAS is present in version 20.8.0.
Step 2: Checking GVMD Manager …
OK: GVM Manager (gvmd) is present in version 20.08.0.
Step 3: Checking Certificates …
OK: GVM client certificate is valid and present as /var/lib/gvm/CA/clientcert.pem.
OK: Your GVM certificate infrastructure passed validation.
Step 4: Checking data …
OK: SCAP data found in /var/lib/gvm/scap-data.
OK: CERT data found in /var/lib/gvm/cert-data.
Step 5: Checking Postgresql DB and user …
OK: Postgresql version and default port are OK.
gvmd | _gvm | UTF8 | en_US.UTF-8 | en_US.UTF-8 |
OK: At least one user exists.
Step 6: Checking Greenbone Security Assistant (GSA) …
Oops, secure memory pool already initialized
OK: Greenbone Security Assistant is present in version 20.08.0~git.
Step 7: Checking if GVM services are up and running …
OK: ospd-openvas service is active.
Starting gvmd service
Waiting for gvmd service
OK: gvmd service is active.
Starting greenbone-security-assistant service
Waiting for greenbone-security-assistant service
OK: greenbone-security-assistant service is active.
Step 8: Checking few other requirements…
OK: nmap is present in version 20.08.0~git.
OK: ssh-keygen found, LSC credential generation for GNU/Linux targets is likely to work.
WARNING: Could not find makensis binary, LSC credential package generation for Microsoft Windows targets will not work.
SUGGEST: Install nsis.
OK: SELinux is disabled.
OK: xsltproc found.
WARNING: Your password policy is empty.
SUGGEST: Edit the /etc/gvm/pwpolicy.conf file to set a password policy.
It seems like your GVM-20.8.0 installation is OK.

Wait even sudo journalctl -b -u <redis service name>? that is illegal

Sorry, I was tired. A month or so ago when I was trying to get “OpenVAS” working on my laptops and trying the recommended journalctl -xe (?) command I didn’t find it helpful, and this time all I really saw was messages about redis couldn’t start.

I knew I did some trick to fix it and I remember reinstalling redis and openvas at some point fixing something so I tried it again and it worked. The journalctl output probably said more stuff that I couldn’t decipher. As I’m studying for the Linux+ certification, I will probably understand how to use and interpret troubleshooting tools like journalctl in the next few months. :woozy_face:

-xe flag shows you everything. Like logs of whole system and -b -u <service name> or -u -b <service name> i don’t really remember shows you the log of only service that you want to check :smiley:

Don’t forget using Enter to scroll down. The journalctl likely uses more to show output.

It took me a month to detect a bug in AnonSurf and i learned the -u -b flag. Everything showed after that haha. That was painful.

Downloading the Parrot 4.11 Security Beta 3 now, will also be testing out Parrot 4.11 XFCE Beta 3 soon!

thank you. I downloaded it and had quick look at the live mode. Everything is beautiful. Redshift is still there and we have a plan to fix it.

1 Like

Tried out the 4.11 Beta 3 for Parrot Security for a day and it was like using 4.10. I just wiped it and installed the 4.11 Beta 3 Parrot Home XFCE.

As you undoubtedly know, quitting Redshift from the panel makes it quickly disappear and then reappear enabled, even if it was disabled before attempting to quit.

IMO, the AnonSurf GUI could use the same icon as used in the Anon Surf menu instead of no icon.

Do we need a sub-menu in the Privacy menu for AnonSurf if there is just one app in it? Nevermind, I just installed the CLI which gave additional menu icons. In Synaptic the description is “Command Line Interfaced for AnonSurf”.

I’ll keep using… :slight_smile:

OH yeah. Idk did Palinuro added redshift or it was installed by some packages (depends maybe) but we can remove it. The funny thing is redshift is not activated in “startup applications” and it was enabled at boot for no reason (in fact it has the problem after a new update) and nobodies changed anything :smiley:

It has no icon? that is impossible. Maybe the screen is too small so the icon had bug. I’ll check it again on VM.

The problem is from when i changed the name of package. I edited the parrot-interface to fix this (include both gtk and cli) but it wasn’t installed. We’ll fix that as well :smiley:

@Masmer oh i forgot about this: what if you use git with ssh key on the beta 3 xfce? Do you have the keyring prompt as same as on Mate?