Parrot xfce 4.11

hello I was wondering if I just have to update parrot xfce to the final version or do I have to reinstall the new beta iso every time? thank you in advance.

You can replace xfce4 config at $HOME by config at /etc/skel/.config/ or do fresh installation. The first way is a little complex but doable. The beta 3 should be final for the XFCE4 unless there are some bugs and we have to changes. So reinstall isn’t necessary. If you are using 4.10 and want to have new XFCE, i recommend you do a fresh installation and wait for 4.11 release is better than reinstall whole OS everytime.
P/s: I hope you love new design of XFCE.

Hello ok thanks

Hi, guys!

I downloaded the new ISO file, XFCE 4.11, I installed it.
Does anyone have a problem accessing other hard drives?
When I need to access other disks, it asks for root password.

As you know the root account is inactive and no password is defined for it.
Later I noticed that my root password (which I don’t have, because it is not defined) also asks for synaptic, to set login screen options and other system options.
In previous versions, the system asked me for my password that I defined during the installation, but now it does not accept it.

1 Like

image
It suppose to ask password of sudo user instead.
i couldn’t test this on VM, unfortunately.
There is a trick that you can set password for root user sudo passwd root or something like that.

https://bbs.archlinux.org/viewtopic.php?id=218083
Not sure if it can help you but i think the user can be configured

I didn’t have much time to look at this, setting the root password solves the problem, but that means the root account is activated, which I don’t want. I want to access system options with a user password (as in earlier versions, e.g. Beta 3).
I think the solution is in polkit and .rules files. I’ll take a look as soon as I have more time.

It is a clean installation on the SSD. I never use VM.
I’ve noticed that for some reason (I don’t know if that’s just the case with me), it still doesn’t set up the hostname properly.
/etc/hostname is fine now, but /etc/hosts content is not good. I manually edit this file to:

127.0.0.1 localhost
127.0.1.1 here goes hostname

# The following lines are desirable for IPv6 capable hosts
:: 1 ip6-localhost ip6-loopback
fe00 :: 0 ip6-localnet
ff00 :: 0 ip6-mcastprefix
ff02 :: 1 ip6-allnodes
ff02 :: 2 ip6-allrouters

I’ll take a look at this as soon as I have more time. I see that there are some guidelines for polkit and .rules files.

some user reported it i think and i believe we didn’t change anything. need some better reports for that.

1 Like

Hi again!
In XFCE 4.11, I was able to set not to ask for “Password for root” when accessing other disks, when entering synaptic and other system options.
Now I am not asked for the password for root, but only the password (sudoers).

The problem was in the polkit configuration files (as dmknght said). I didn’t have time to look which setting specifically caused the problem. Since this part worked properly in XFCE 4.10 version, I copied all the files from the specified folders (from ver. 4.10) to the same folders in ver. 4.11:
/etc/polkit-1/
/var/lib/polkit-1/
/usr/share/polkit-1/

After restart, everything worked as it should.

Thank you. Nice to know. But i’m wondering why it is like that in 4.11. I think i should check the installer again

I think it’s something up to the installer, too. Because it doesn’t set up the hosts file well either.

If anyone needs the correct polkit files, I will upload them.
polkit_files.tar.bz2 (100.8 KB)

Hostfile is something different. It should be fixed. Polkit is special problem and i didn’t see any commit that touches this polkit thing.

Hello nous. I installed the security distro today with KDE and am finding the same issue. I have some linux experience but none with editing system files, and the files to be edited are locked and unviewable in the GUI. Any ideas on a good tutorial on learning how to accomplish this editing task? I can start installing stuff through the command line but that can get touchy with the package manager is my understanding. But I have things to do also. I downloaded your corrected files already and just need to understand how to implement them. Thank you for your help!

Hi, toaster802. Sorry I didn’t answer right away, I was at work.
In XFCE I simply run Thunar as a sudoer (in the terminal I run sudo su, (password), thunar), after which in root mode I copy everything I need.

In KDE, you can’t run Dolphin easily as root (they set a restriction). I haven’t used KDE for a decade.
Google “run dolphin as root” and start Dolphin that way, then copy what is needed.
Or, use the cp command in terminal as a sudoer.

Thank you Sir! I was able to find this work around after several hours, and I appreciate you getting back to me. Hopefully it will be patched soon. Have a great day.

I have this idea: Why don’t you compare different between folders of 4.10 and 4.11. Maybe we can know what changed :smiley:
P/s: sorry i must work on it but i’m busy on other projects so i can’t do it for now.

I planned it as soon as I had free time. My regular job takes me a lot of time. I will try to compare the differences for the weekend.

Hi, dmknght! I check the differences between the polkit configuration files today (in versions 4.10 and 4.11). The picture is attached.

The problem is in one file: /etc/polkit-1/localauthority.conf.d/51-debian-sudo.conf
It is missing in version 4.11.

When I added it, everything works properly after the restart.

This will provide answer to several running topics related to root password, running synaptics, etc.

1 Like

Thank you man i love you so much. let me tell it to the team

1 Like