ParrotOS 4.6 QA/Testing Discussion

  • Place to discuss issues and problems pertaining to ParrotOS 4.6 beta testing.

  • This is not the proper place to post your ideas and tips.

  • Please post your full report in the Parrot 4.6 beta testers program

We are currently on release candidate 4.

Note: If your post has been moved it, it was not found to be a complete report. Please either revise and resubmit or continue your discussion here.

1 Like

Regarding nm-applet crashing when attempting to connect to a hidden AP, I have found a temporary solution. :slight_smile: @rootCode, I believe this may help you.

1 Like

@palinuro, it appears the issue is with apparmor. I got it working in the 4.6rc4 liveusb.

1 Like

Here is my quick test

  • We are having duplicate tools: remmina vs vinagre. Both are remote desktop viewer client. I think we should remove one and keep one (i think remmina is better)? (We are having clawmail vs thunderbird as well)
  • Remove vim-tiny and install vim by default. (vim command not found)
  • It is better if we move radare2-cutter shortcut in menu from "Programming" to "parrot reversing"
  • Metasploit works and libreoffice crashes. Run libreoffice without firejail gives me no different
  • Default bettercap was disabled (that is good).
2 Likes

ParrotSec 4.6 rc4 (Beta) still has following major bugs:
1. Live Mode not booting (Stucks at Parrot Logo) via UEFI mode but Legacy boot works (syslinux-6.04) - Rufus
2. Mate Tweak changes from GNOME2 > Fedora but can't change from Fedora > GNOME2 (Remains unchanged)
3. Screenshot not working via PrtScSysRq button when any selection panel is open
4. LibreOffice Fatal Error: Signal 11 not occurring in VM (VirtualBox) didn't tested via others

1 Like

LibreOffice issue seems to be an apparmor issue. I’ll go ahead a grab a UEFI system and test the 4.6rc4 ISO, I haven’t tried that yet.

Regarding Mate Tweak, I feel that is an issue with Mate Tweak. I found that if you save the current panel layout as a custom layout, name it etc. It can be switched without breaking the default look.

1 Like

I think that beside appamor issue here Mate Tweaks also added to the list. Signal 11 can be also occured because of other errors. Lots of Debian based distro users are also facing this shitty problem of crashing at the time of LibreOffice starts, also tried to rename, delete & modify the lib files but nothing happens. There might be other major bugs

I found out your UEFI issue. When booting in Legacy Mode, the option “apparmor=0” is removed.

When booting via UEFI, ‘apparmor=0’ is still there, preventing the system from booting properly. When removing this option, apparmor loads correctly and the system boots using UEFI.

apparmor=0 was used in 4.5 ISO to disable apparmor at boot. Attempting to disable apparmor at boot in the 4.6 ISO makes the system not boot, for reasons I do not understand.

1 Like

The option when booting in UEFI mode, ‘apparmor=0’ prevents the 4.6rc1 ISO from booting on UEFI (Secure Boot disabled) systems.

It’s Open source && Very Good :sunglasses:
Apparmor killing service even disabled
Not libreoffice bug

2 Likes

Evolution is not a bad choice. It supports Exchange server.

1 Like

For Apparmor=0, ParrotSec 4.6 rc4 is not booting via UEFI mode but in the Legacy mode :laughing:

  • It is late a little bit but is there any chance to include gef plugin for gdb by default?
  • Request pre-installed ftp. It is useful for ctf and normally use (sometime)
  • enum4linux and samba wasnt in preinstalled list. Removing samba saves startup resource (startup service, open ports) but enum4linux is a common enumeration tool. Should we add it to pre-install list?
  • Firefox is having so much broken bookmarks (for example chat.parrotsec.org). I think we should clean them in this release.
1 Like

That would be useful. What is “ftp-rfc” command then?

https://tools.ietf.org/html/rfc959 got this from google. It is a long documentation and i don’t really understand it :’(

Nop it is Not with Apparmor, it is with firejail, I just installed parrot 4.6 to hdd last night, I disable apparmor, but the problems still was present, the just removed firejail and firejail-profiles, and libreoffice starts without problem.
I believe it does not require a full report, anyone can try and test it, just to confirm. cheers°

Is apparmor and firejail two different packages or do they work with each other? Sorry, I’m new to both and since firejail is running on my machine but apparmor is not, I assumed that it was an issue with apparmor.

they are different. apparmor is in the lower layer, firejail is a sandbox app. I think firejail is trying going deeper inside apparmor

1 Like

LibreOffice is key - Parrot used as a daily driver and even for pen testing it is the only way to get information in/out to people in business, managers, customers and contacts (because of its MS Office compatability).

The problem seems to be firejail profile - run LibreOffice without (–noprofile) it’s good - therefore “we” neeed to tweak our firejail profile for LibreOffice - that’s it.

1 Like

i have many problems when changing networks (wifi to lan … and back)
network manager is not a big help … sometimes i could not enable wifi adapter and so on.
stopping anonsurf to got a working dns sucks too. :wink:

is there a simple way to build a status icon for anaonsurf in the taskbar? green = anaonsurf on
red = anonsurf off.

booting with uefi works on surface 4 pro. All the other stuff looks betten then the stable release :slight_smile:

1 Like